All Downloads are showing as "hidden" on mac

Description of the issue:
When I download files from Brave onto my mac, they are now hidden. I’ve tried other browsers and programs to download files, but the only affected source is Brave. I have traced it back to the fact that when a file is downloaded from brave, it shows up as “.com.brave.Browser.[unique ID]”.

My assumption is that because that prefix starts with a “.” that mac is hiding that file, even if the filename is changed after the download completes.

How can this issue be reproduced?

  1. Downloading any file.

Expected result:
It should download the file without hiding it.

Brave Version( check About Brave):
Brave is up to date
Version 1.58.135 Chromium: 117.0.5938.140 (Official Build) (arm64)

Additional Information:
I am also using the most up to date mac os version (not beta).
macOS Sonoma 14.0 (23A344)

I am finding the same results. All downloaded files have “Invisible” set. Note: I am downloading to /Downloads on iCload.

Just to echo I’m having the same issue on Sonoma - all file downloads are marked as hidden.

1 Like

Same. Downloads invisible using Brave.
Seems to be fixed in v1.60.110

Hmm — very strange. I am not seeing this behavior on my end. Does it matter/make any difference if you save the file on iCloud vs locally? Would also be good to confirm whether or not this behavior happens in a new profile.

Same here. I’m using Brave Version 1.60.118 Chromium: 119.0.6045.163 (Official Build) (arm64) on a M2 running Somona 14.1.1 (23B81). It’s really annoying!

Weirdly, the files are only hidden if they are downloaded directly to the desktop. They are visible if downloaded to any other folder. The problem only started when I upgraded to Somona.

I’ve been having this issue for weeks too, it’s been extremely disruptive to my workflow… :sleepy: and is absolutely not fixed yet in v1.60.118 (Chromium 119.0.6045.163)

I assumed it was the Sonoma update/an iCloud issue but in response to an earlier question, it doesn’t matter where I try to save something (local, iCloud, Dropbox, Google Drive), or what kind of file it is – all fail to appear.

My exhausting workaround is to search by name for the item, send to trash, and then go to trash and “put back” – then it appears where I originally downloaded. Specs below.

Sincerely hope you guys can fix this!!

Screenshot 2023-11-23 at 09.44.08
Screenshot 2023-11-23 at 09.43.17

I am having the same issue on the following:

  • 2018 Macbook Pro 15"/4 USP jacks and
    -2020 Macbook Air 13" (M1)
    -2020 Mac Mini (M1).
    -all using Latest Sonoma (v14.1.1)
  • Latest Brave ( Brave is up to date
    Version 1.60.125 Chromium: 119.0.6045.199 (Official Build) (x86_64)

More Info just in:

Hidden on: Downloads folder (on iCloud Drive, created by user) in reality at /Users/my-user/Library/“Mobile Documents”/com~apple~CloudDocs/Downloads/

Hidden on: my Home folder at /Users/my-user/

Visible on: Desktop “folder” (on iCloud Drive but handled by OS) /Users/my-user/Desktop

Visible on: Documents “folder” (on iCloud Drive but handled by OS) /Users/my-user/Documents

Visible at: Root of iCloud Drive /iCloud Drive but in reality stored at /Users/my-user/Library/“Mobile Documents”/com~apple~CloudDocs/ (no asterisks)

Desktop and Documents are almost certainly in directories stored at /Users/my-user/Library/“Mobile Documents”/com~apple~CloudDocs/

I was beginning to think that the issue, at least for me, is connected to the fact that I have created a directory “Downloads” that is meaningful to the OS and placed it in iCloud, while all the other bsituations are in directories directly handles by the OS. I don’t know how that relates to the hidden flag. But it seems to correlate with it. However the fact that it is also hidden on my Home directory doesn’t fit. So I laeve this to better minds than mine.

Thanks for a great tool/app/browser.

I have the same problem on Version 1.60.125 Chromium: 119.0.6045.199 (Official Build) (arm64). Using MacOS Sonoma 14.1.1. If I save to Desktop, it is hidden.

Here’s a workaround:

  1. Click Downloads to the right of the address bar
  2. Click Show in Finder next to the image. You’ll see the hidden image.
  3. Right click the file
  4. Go Quick Actions > Convert Image

Screenshot 2023-11-30 at 10.54.53 AM

Screenshot 2023-11-30 at 10.55.04 AM

1 Like

Thank you. That’s a big help.

Exact same issue here. It’s been several months at least. My workaround is going to Brave Downloads and opening the folder. The file will show greyed out and I double-click it to get it to fully appear.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.