Address Bar Input Lag

Description of the issue:

There is a intermittent lag before text input after clicking on the address bar.

How can this issue be reproduced?

  1. Click on address bar to initiate text input
  2. Begin typing web address or search term
  3. There is an intermittent lag between keyboard input and text appearing in the address bar

Expected result:

Typing input should be visible immediately upon keyboard in put.

Brave Version( check About Brave):

Version 1.18.78 Chromium: 87.0.4280.141 (Official Build) unknown (64-bit)

Build is brave-bin from the Arch Linux User Repository. OS is Arch Linux with KDE Plasma 5.20.5 Desktop

Additional Information:

Issue happens about 75% of the time when trying to type in the address bar. It happens with both new and existing tabs.

The problem happens with hardware acceleration both on and off. My chrome://gpu matches the entries in Chromium which does not have the issue.

I’m wondering if it is a browser extension you have installed? Can you try creating a new profile and see if you get the same behavior when using the new profile?

Thanks for the troubleshooting idea. The only extension I am running is KDE Plasma Integration. Unfortunately the behavior is the same whether the extension is on or off.

Did you try with the new profile?

Switching to a new profile seems to have fixed the issue based on limited testing of an intermittent problem. It seems much snappier now with both the KDE Plasma Extension on or off.

The key difference between the original profile and the current profile was the original profile imported data from Firefox. The new profile only imported passwords and bookmarks from files exported from Brave. That could be the difference.

Thanks for your help.

Could be – I would imagine clearing cache/browsing data for all time in your old profile would probably resolve the issue as well. But regardless I’m glad you’ve got the browser working as intended.

I wanted to provide an update on this issue.

The issue comes back over time. It seems to be related to the auto complete feature. As history builds up over a few days the lag starts again. Turning off auto complete eliminates the lag so it appears that there may be a bug in the implementation of auto complete. Note that I have auto complete turned on for only history and bookmarks. I have the other options such as top sites, suggestions, etc. turned off.

When I originally posted this issue I was on version 1.18. The problem has continued in 1.19 and 1.20.

This issue still exists after several updates. I am currently on 1.21.76. Is there any more info I can provide so the developers can diagnose and fix this issue?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.