Brave search bar completion very slow last few months

When typing in the search bar at the top of the browser I have very bad lag.


Disabling all of these speeds it up, (but that makes the search bar not that useful)

Disabling some doesn’t have a noticeable improvement. I need to disable all of them. I’ve tried in incognito with no extensions doesn’t help. Chrome is fast for me, but firefox is the fastest, which is a bummer for me.

Seems to be an input lag in the browser. I can type a lot of things, press ctrl+t and type another search, and then after a pause everything I typed in happens. Only have this issue in brave.

Have tried updating brave through several versions, but they all have the same issue. On the latest one currently.

Hello @aareman, thank you for reporting this. Have you tried by deleting cookies and cache? Do you have extensions installed? If so, please try to remove them and relaunch the browser.

Besides this, can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Hope it helps. Regards.