Adding new search engines (SearX) and setting them to default problem

I have Brave Version 1.37.111 Chromium: 100.0.4896.79 (Official Build) (64-bit) installed on Windows 10. I am trying to add a Searx instance as my default search engine but I can’t seem to achieve this.

To do this in Brave I:

  1. Went to brave://settings/searchEngines
  2. Clicked the ‘add’ button in the ‘Other search engines’ section
  3. Set Search Engine as ‘SearX’, set Keyword as ‘:x’ and URL as ‘
  4. This successfully added Searx to my list of Search Engines in the ‘Other search engines’ section.

However, when I click on the 3 dots icon for that entry, ‘Make default’ is greyed out and unavailable. Edit and Delete are available. Please see this pic (hosted on imgur) to see what I have done.

I have also tried performing a search on the SearX instance page and then checking the engines list. This also does not work. I have also tried restarting the browser.

Is there something I’m doing wrong? How do I resolve this?


Try to set Search URL as- or this-

Both worked for me. And I can’t save the search engine without “%s” in the search URL.

1 Like

First URL worked perfectly. Thanks :slight_smile:

Doesn’t really matter, but do you happen to know why the ‘s’ matters?

EDIT: Never mind, I just noticed the instruction in the ‘add’ field. Must’ve missed it before.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.