Accumulated BRAVE REWARDS missing after browser version update

NOTE: Any “one-liner” or topics requesting support or reporting bugs that do not make an effort to include as much of this information as possible will not be responded to. Repeatedly posting as such is grounds for banning._
Please try to adhere to this template when reporting bugs. If you think you don’t need to fill out every section in the template fill out as much of it as you can and please be as descriptive as possible when posting.
<---------Delete this line and everything above before posting---------->

Description of the issue:
Was on version 1.0 of brave browser and had accumulated 21.9 BAT rewards from watching ads and web pages.

I hadn’t received any ads in a long while and was not accumulating rewards so I eventually clicked on the in-browser update button on the upper right and completed the install of the new browser version.

NOTE: During install I chose a new install path, in my thinking, as a way to safeguard the current browser showing 21.9 bat and allowing the updated browser to install successfully where I would sign-in and verify my rewards.

As described, the new version shows my BAT rewards as 0.00 and the older version of the browser does not let me open it, as it comes up with an error message that stated…
> Profile error occured

      Your profile can not be used because it is from a newer version of Brave.
      Some features may be unavailable. Please specify a different profile directory or use a newer 
      version of Brave."![Screen Shot 2021-01-29 at 5.13.48 PM copy|690x431](upload://vYXWe55sIQErCHorPqxGXp2JJnM.jpeg) 


Steps to Reproduce (add as many as necessary): 1. 2. 3.

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:

Operating System and Brave Version(See the About Brave page in the main menu):
Current version 1.22.71
Additional Information:

Please help me get my rewards back, thank you Community.

Apologies for the formatting errors in initial post, first time poster.

Hi @royalwichiz,
Can you confirm what macOS version you’re using?
For installation - did you run the installer or did you click update within Brave?

Hello Aa-ron,

I am using and was using macOS 10.13.5. I clicked update from within the browser.

My Brave browser version is currently
Version 1.22.71 Chromium: 89.0.4389.114 (Official Build) (x86_64)

Other than my pending Brave rewards, the browser has “remembered” my bandwidth usage savings, time savings, and ad blackage numbers (as seen in attached screenshot).

Thanks for your reply.

Hi @royalwichiz,
I believe the issue is that your running two installations of Brave. I suggest you remove the new one, go to https://brave.com/ download a new installer. Run the new installer, if you get a prompt to replace or keep both, please click replace.

Hello,

I am having the same problem using macOS 10.15.7. I followed your steps and it didn’t work. my brave broweser remembers my bandwidth/time/savings etc and even shows me my BAT accumulated, but it shows as 0.0. And now I can’t even see my brave rewards settings. Any help is much appreciated. Please see attached screenshots.