60FPS Youtube videos lag when mouse is still

When I watch 60fps youtube videos in fullscreen, the video will be very choppy and perform poorly unless I trigger the control interface by moving the mouse. The performance cleans up instantly when I move the mouse. When I let control interface fade out again the video instantly becomes choppy again.

How can this issue be reproduced?

  1. Happens when viewing 720p60fps or 1080p60fps youtube videos in fullscreen.
  2. Change the settings in the youtube video viewer to force high quality 60fps playback (on a video that supports 60fps).
  3. Watch the video in fullscreen.
  4. Video will not play smoothly when the control interface is hidden.
  5. Moving the mouse shows the control interface, the playback instantly becomes perfectly smooth.
  6. Resting the mouse lets the control interface face out, the playback instantly becomes laggy again.

Expected result: The video should perform properly regardless of the control interface presence

Brave Version( check About Brave): V1.32.113 Desktop Windows 10 64-bit 21H2

Additional Information: Issue does not happen when hardware acceleration is disabled.
Also does not happen while recording my desktop (so I can only provide phone camera footage). Doesn’t happen in Edge, Chrome, or Firefox, regardless of hardware acceleration settings. Also not happening in Brave Mobile on my android device.

MP4 video recorded with phone
Hard to notice, here is a guide:
0:00 I let it lag at first.
0:07 I move the mouse smoothing the playback.
0:20 I rest the mouse, letting playback lag.
0:27 I move the mouse again. I think this is the most noticeable transition.
0:36 lag
0:40 move mouse, smooth

Test in private window, no extensions. Which GPU is used on the system? I know integrated graphics is a lot more problematic (when hardware acceleration is enabled)

I see the same behavior in a private window. This is a new install and I haven’t added any extensions.
Also I have checked if “Shields Up” or “Shields Down” has any effect. (It has no effect).

The GPU on my Windows PC is a PCIe 4.0x8 Radeon RX 6600 XT.

sample video, and does stats for nerds (right click on video) show anything?

This looks like a good sample video, better than my first one.

Stats for nerds screenshot below. I’ve noticed that the count for dropped frames grows when it is lagging (no control interface), and doesn’t grow when it is smooth (moving mouse to keep interface showing).
StatsforNerds-Gatto2600

https://support.google.com/chrome/thread/77636044/chrome-to-use-specific-gpu?hl=en

Is there more than one GPU? Also https://www.youtube.com/watch?v=Cyxixzi2dgQ is only showing a 720p version for me, do you have any youtube extensions?

#edit viewport isn’t the display resolution. my err

This is a new PC and new install of Brave Browser. I have no extensions. The Extensions screen is blank and shows me the “Find extensions and themes in the Web Store” message.

My processor has no integrated graphics, so RX 6600 XT is the only GPU in the system.
Brave://gpu/ pastebin Seems hardware acceleration is supported.


I tried setting “High Performance” here, as I saw in your link, and restarted the PC. It made no difference.

Try this extension, does this work better? https://chrome.google.com/webstore/detail/enhanced-h264ify/omkfmpieigblcllmkgbflkikinpkodlk?hl=en

No this did not fix it.
It did change the codec from vp9, but not to h264. It went to avc1. Frames are still only dropping when the control interface is hidden. And frames stop dropping when I move the mouse.
Gatto2600-StatsforNerds 11-28

Here’s a screenshot of the settings I have set for this extension. I restarted Brave after setting it.
h264ify