2 finger scrolling on trackpad freezes Windows 10

Description of the issue:
2 finger scrolling on the trackpad of a Microsoft Surface Laptop 2 frunning Windows 10 freezes constantly. I am able to use the scrollbar to the right and scroll, but not on the trackpad.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
It is happening frequently, but randomly. Even as I am typing this message, the scrolling freezes. If I switch to another tab and then back, it will scroll. It appears to be the only way to fix the issue, but only temporarily. It is hard to point to a specific way to reproduce the problem.

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:
It happens often. I currently have 5 tabs, but it will happen even if I only have one tab open.

Brave Version(about:brave):
Version 0.59.18 Chromium: 72.0.3626.28 (Official Build) beta (64-bit)

Reproducible on current live release (yes/no):

Additional Information:
I have switched to Chrome on the same websites and it works fine in Chrome. I wanted to make sure it was not a hardware problem.

I have tested scrolling with two fingers using my laptop (msi gs65) and I was unable to reproduce the issue. I opened 5 tabs. Tested with Brave 0.59.20.

@tompap Can you open Task Manager and check if there is a process that takes a lot of your cpu when scrolling?

1 Like

The CPU being used for Brave is 2%. The moment I scroll it jumps to 13%. Overall, my CPU usage is in the 8% range when not scrolling in Brave. The problem still exists, again only in Brave, not other browsers. Thanks for your input!

Can you try disabling Hardware Acceleration in settings?
To do so, navigate to: Settings --> Advanced --> System --> Hardware Acceleration

Let me know if this helps or resolves the issue.

I have tried that. Turned off hardware Acceleration in settings, then relaunched the browser. Same results. I am a bit flummoxed by this scrolling behavior as it is only happening in Brave and not other browsers. Again, appreciate the input and ideas. Would love to get it resolved as I do really like the Brave browser much better than Chrome.

I decided to do a hard reboot after turning of the acceleration instead of just a relaunch of the browser. I’ve given the browser a bit of a workout with scrolling through a number of sites and it appears to be a bit better. It has frozen yet, I’ll continue and see if this was the resolution. Thanks again!!

Was just coming to reply and suggest a reboot of your machine as well. Sometimes System settings like that need to be kickstarted into action. Appreciate your patience.
I’ll leave the thread open for now in case you encounter the error again.

After a few days of heavy use of the browser, turning off hardware acceleration and rebooting appears to have done the trick. Not a single instance of freezing with a 2 finger scroll using the trackpad.

Thanks for your help and the suggestion. Hopefully, this will help anyone else who may experience this issue.

1 Like

It was my pleasure!
Enjoy your privacy!