1.12 update deleted all bookmarks, favorites, history, open tabs

Description of the issue:
1.12 update deleted all bookmarks, favorites, history, open tabs

Mobile Device details
ipad pro 12.9" 1st Gen 128Gb
iOS 12.2

1 Like

Same. Everything has been erased on iPad mini 2.
I need to restore.

Same here, but only on iPad, not on iPhone. I was able to sync bookmarks back to iPad, but lost my iPad history and open tabs.

Same problem with my iphone 7, IOS 12.4.1. Also, was using a Proton VPN if it matters.
All previously opened tabs, history, bookmarks have vanished.

Unable to reproduce this on iPhone/iPad.

Could anyone of you provide more info on these:
Was the app in memory when the update happen or was it closed(removed from app list)?
Was this update from 1.11.4 or an older version?

In memory.
And surely updated from 1.11.4

Howdy, yes, the app was in memory. Prior to today’s update, the version on my phone was 1.11.4 (i always update brave to the current version).
Please let me know of further questions. Good luck, friend.
Just prior to yesterday’s update, i began using Proton’s VPN. I have since disconnected from the VPN.
The first thing i tried was restarted my iphone but no joy.
Also, i tried deleting it and reinstalled but no joy.

In memory. And updated from the 1.11.4.

@totalencounter @vdb just to confirm were you guys on VPN as well when the update happened similar to @Trifector ? Just want to narrow down

I was indeed on NordVPN on my iPad (and not on NordVPN on my iPhone).

I was on Adblock mobile VPN.

Thanks for the confirmation. We’re going to look into this.

Looping in @michal and @joel from iOS team

Sriram, I will try another iphone (iphone 6S vs 7) I have and update to the new Brave version AND will not use the VPN. Will let you know in a few

That would be really helpful info. Thanks @Trifector

Sriram, just updated to the current version of Brave on my iphone 6S without a VPN connection established and it worked. Bookmarks, history, prior opened tabs still persist.
Both phones were on the same version of IOS.
It appears the only diff was the existence of a VPN connection and iphone versions, 6S vs 7.

Good luck.

Thanks a lot for testing @Trifector. That definitely helps. We will investigate the issue further. I’ll keep the issue open so that others can chime in if they run into this as well.

In memory, from 1.11.4, but no VPN in use.

Quick question did anyone you set to Private browsing only mode from settings on 1.11.4?

No I did not. Always normal mode.

Same problem here, i’ve updated from version 1.11.4 as always i do and when i opened all history and bookmarks were gone.
No VPN connection estabilished, i have Ios at latest 12 update, and when i updated brave browser was not in memory, normal mode only no private mode.