Youtube URL not working on Brave Browser

Description of the issue:
Youtube links always open up with a bit in the URL, the appearance is altered and unaesthetic + videos don’t launch

Actual Result (gifs and screenshots are welcome!):

Expected result:
Get the classic Youtube UI back.

Reproduces how often:
This issue is always effective : i can’t read any Youtube video using Brave Browser on PC

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 64bits ; Brave version (currently up to date) : Version 1.13.82 Chromium: 85.0.4183.83 (Official Build) (64-bit)

Additional Information:
I have tried reinstalling Brave entirely and using special links such as with no positive results. My issue is similar to the one described here : but only occuring with the Brave Browser, however youtube works perfectly on Chrome & Opera.


could you try to use private mode and see if it work fine ? and disable all extention

1 Like

Can you try clearing cache/browsing data for Youtube, then see if you are able to access the desktop version of the website? The quickest way to do this is to visit Youtube, click the Lock icon in the address bar, then Site Settings --> Clear data.

Note that you’ll have to refresh the page before the change takes effect. Let me know what you find out.

Thank you ! Youtube works fine in a private mode window. However disabling all extensions doesn’t fix it if i get back to a normal browser window

Have a good day

I did that yet after clearing all this data

and resetting the permissions + closing and opening Brave again didn’t fix it. I also tried to log out and same result.
Have a good day

Hey guys ! I found how to fix it, by creating a new browsing profile :

I keep the old one just in case (though i did transfer all the password with the .csv file) and i have one profile that is fully functional on Youtube.
Dunno why i had this issue, but in case u have it : create a new profile.

1 Like