Your browser is managed by your organisation

Brave says at the bottom of the menu “Managed by your organisation”, and following this item goes to brave://management/ which also says the browser is managed by my organisation. This is my personal computer and not managed by my organisation.

Looking at brave://policy/ I see a single entry for ExternalProtocolDialogShowAlwaysOpenCheckbox which is set to true.

This policy links to where I can see it being true allows me to select Always allow in the prompt for opening a specific protocol. Surely that is the default.

Anyway, where can I get rid of this policy setting on a Mac? I don’t understand how it has been set since I haven’t used this Mac with any work systems that might have set this. Is it possible that selecting “Always allow” in the protocol dialog box might have triggered this?

I read a message saying that the browser is managed as a privacy warning, and since I don’t see why it should be then it is quite a worrying one. False positive? suggests that it is possible to use the macos terminal command defaults to remove policies.

Brave polices are in the com.brave.Browser domain.

I was able to remove the policy with the following command:

defaults delete com.brave.Browser ExternalProtocolDialogShowAlwaysOpenCheckbox

On restarting Brave the message that the Browser is being managed was no longer there.

I am not sure how to test whether ticking the Always allow box in protocol dialog adds this setting back into the defaults and if this triggers the management message as I am unable to get the dialog box. Can anyone advise how to check?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.