Yahoo finance charts broken

Description of the issue:
With the latest update, yahoo finance charts are not displaying.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
go to https://finance.yahoo.com/
then select a stock e.g. tsla
then click on “chart”.
We now get a blank screen.

Actual Result (gifs and screenshots are welcome!):

Expected result:
See expectedResult_Chrome.PNG


Reproduces how often:
Reproduces always.

Operating System and Brave Version(See the About Brave page in the main menu):

Brave is up to date!
Version 1.11.104 Chromium: 84.0.4147.105 (Official Build) (64-bit)

Windows 10

Additional Information:

if this work

then make sure that Cookie blocking set to cross-site cookies blocked

hope that help and have a nice day :slight_smile:

1 Like

@justsomeone1,
Good suggestion – however, in my experience this issue (charts/graphs not displaying correctly or at all) is often caused by Brave’s Fingerprinting protection.

@mzallocco, can you try visiting the Yahoo! Finance page, open your Shields panel in the address bar and change the Fingerprinting option to Allow all fingerprinting?


Allow the page to refresh and see if the chart now displays properly.

thanks for the info and have a nice day :slight_smile:

1 Like

Allow all fingerprinting did not help.
One other thing i should mention is that the chart appears for a fraction of a second then disappears.

Cookie blocking set to cross-site cookies blocked did not help.
I tried all combinations of shield settings, did not fix the problem.
The chart appears for a fraction of a second then disappears permanently

idk why i tried to open it for 3 min and it still there without issue but i use linux hope @Mattches help you

@mzallocco,
A few more things to try:

  1. Try turning off Hardware Acceleration (Settings --> Additional --> System --> Hardware Acceleration) and see if the chat displays.
  2. Right-click on the page, in the context menu, select Brave --> Clear CSS rules for this site. Refresh the page and see if the chart appears.
  3. Can you try visiting the site in a Private browsing window and see if the chart appears?

Nr 1 and 2 did not help.
I went ahead and disabled the Google Application Launcher for Drive extension and the AdBlock extension, did not help.

With private browsing, the charts were visible/worked.

1 Like

Well that’s just crazy.
Can you try clearing your cache/browsing data (for all time if possible but I understand you may want to keep some of that info so as far back as you’re willing to go) and see if you are able to view the chart after that?

ok i tried removing the last 4 weeks of cache. No help.
Removed all cache and now its working.

One other thing, with the brave update, the vpn software I have been using with Chrome now works.

glad it worked well done and have a nice day :slight_smile: