Wrong Timezone in new tab


I have searched and found a few threads about this topic and all of them have not been solved. Anytime I open a new tab the clock is wrong. I need this solved ASAP as this will cause me to have to revert to Firefox or another browser and leave the Brave community. I enjoy this browser immensely and would hate to switch out but this issue is unacceptable.

Brave is up to date

[Version 1.9.76 Chromium: 81.0.4044.138 (Official Build) (64-bit)]

I have seen this exact topic left until it closed automatically and need support to be better than that. If there is a closed thread or something that has been fixed I need it sent over asap.

Check your PC region, check your system clock, check your language in the Browser and check what time comes up when you look up “time” on Google.

Region is correct, system clock is correct, time in google says correct time, language is correct. Tried rebooting, setting everything to be automatic in windows 10 clock settings.

Well, I’m out of ideas. What time is it showing and what is your current time?

Brave shows 3:03 and System is 2:03

Bump. Will be bumping daily till it gets answered.

Wow, off by an hour is weird. The posts I’ve seen before had it off by 12 hrs because the language setting forced 24 hr time or 12 hr time. This one … @Mattches, have you any idea what might be up if @spooneythecow’s other time settings are in order?

1 Like

I had a pop up at one point tell me my time zone wasnt correct but that only appeared once and I cant find where the setting to change it is.

As @hnktong said, that is weird that it’s only off an hour. Regardless, the browser is using your System/locale to decide what time to display – is the time on your PC also off by an hour?

No PC time is just fine as well as the Time when you ask google or anywhere else. Its localized to brave.

Can you check and see if your System time is manually set or is the Automatic option selected?

Fully Automatic

Wait that is interesting. I happen to be in MST. that would mean that my time zone is wrong but the time is correct. That is very odd.
Hmm even after changing that the tab still is an hour later.

Thank you for confirming. I’ll have to reach out to some of our devs about this as I don’t know what would cause the clock to be only an hour off.

Bahaha oh man I found it! Daylight savings is a cruel mistress. Right under that it has the setting for automatically adjust for daylight savings and that was defaulted to off. Once that was on and everything was set to automatic I re synced the system and walah! it all lined up! Figures it was an issue between the chair and keyboard.


Phew! Good find – glad I didn’t have to give the devs another bug to deal with :stuck_out_tongue:
Appreciate your patience.

1 Like

This topic was automatically closed after 18 hours. New replies are no longer allowed.