Windows can't find and open Brave

Description of the issue:
Brave does not open at all. I get a windows error message stating that windows cannot find the file required to open it, which does not make sense because the file it “can’t find” is right there in the folder.

How can this issue be reproduced?

  1. Click/double click the Brave desktop shortcut, the Brave icon on the bottom menu bar, or the actual application file in the program files x86 folder.

Expected result:
Brave opens.

Actual result:
Brave does not open.

Brave Version( check About Brave):
I cannot open Brave to check the version, so whatever version is downloaded directly from the brave website.

Additional Information:
This very well could be a windows issue however this only happens with Brave. In case it makes a difference; I’m using windows 7.

Hi, you may have to reinstall Brave again. The application should execute from the following location.


I appreciate the response, thank you. However uninstalling and reinstalling didn’t fix the issue. How do I make it run from that file location?

After installing Brave, did you make any changes to the installation location? Also, if you just type Brave into the Windows search bar and open the application as it appears there, do you get the same result?

@Mattches if i type brave in the search bar and click the application file that comes up it gives me the same pop-up instead of opening :o

and no, i don’t change where the file installs at all? double-clicking the setup brings up the “are you sure you want to let this file make changes to your computer” pop-up and if i click yes it immediately starts the installation. I think i would have to go out of my way to change the file installation destination and i haven’t been :0

I have no idea how or why it works but I tried changing the application name to “brave.exe.exe” and it…suddenly started working. I don’t know if it’ll ever stop working but I’m able to open brave now at least.

That’s…very strange. I honestly can’t say that I’ve ever seen this type of issue before. And I assume you never changed the file name (intentionally) at any point?

Not since re-downloading it about 2 hours ago? I’ve had the issue before now that i remember, it wasn’t the first time I downloaded brave but after an update? I figured that because the file was just named “brave” and my pc wanted to open a file name “brave.exe” i would just add a .exe even if it was already technically called that? I didn’t think that that would work this time/i thought it was caused by something i had done that first time, so when it didn’t work upon installation i thought i had done something wrong. Never let it be known that i understand anything about how computers work :joy:

1 Like

Yeah that’s certainly a new one. Thank you for informing us – I’ll be on the lookout in the event any other users experience the same issue.

This topic was automatically closed after 30 days. New replies are no longer allowed.