When Brave blocks autoplay, Vimeo videos will not play AT ALL

Posted this in May but got no response. Still isn’t fixed, so I’m posting again with @Saoiray , since he’s helping with another problem I reported.

When autoplay is blocked, Vimeo videos won’t play at all.

  1. Block Autoplay in Settings
  2. https://brave.com/whats-new/
  3. Click Play in the middle of the news-feed video
  4. Click Play on playback controls
    5.RESULT: Nothing happens
  5. Click “Vimeo” icon on the playback controls to open https://vimeo.com/794414940
  6. Click Play on the playback controls
    8.RESULT: Nothing happens
  7. Click “Autoplay was blocked” icon in Brave address bar and allow autoplay for this site
    10.RESULT: now playback works

100% reproducible in profile with no extensions.

Thanks for sharing @100WattWalrus. I was able to replicate this and so created an issue for it over at Github. I’ll also tag @Mattches on it so he’s aware and can tag anyone in on it if necessary.

Problem exists with giphy.com too.

I suggest the real solution is for there to be more than just “always” and “never” options for this feature. Especially since allowing makes the icon for controlling autoplay disappear, so you have to go digging through settings if you want to reverse it (and this setting is not easy to find).

In short, we need an “allow this session” option.


@100WattWalrus Mattches was able to reach out on that and they have it assigned to a P2 priority. So it will be something that devs will be looking into here. I can’t speak as to how quickly, but it’s definitely up on higher priority than most issues.

1 Like

Thanks for the update, @Saoiray .

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.