Website not loading completely

When I go to [], the page doesn’t load completely, I have to reload it. All shields are disabled.

Brave Version): 1.5.123 32bit

1 Like

Not sure what I’m exactly checking for, but I had no issues loading the site; (From an NZ IP)

Version 1.5.115 Chromium: 80.0.3987.149 (Official Build) (64-bit) and just updated to 1.5.123, and same result. Page loaded. Maybe try via a VPN as a test on a different location?


with VPN I got an errror:


without VPN, at first:


the developer tool shows errors:


after several reloads (or sometimes new tab or restart):


with Google chrome there was never this issue, only difference: you have the 64-bit version where I’m still stuck with 32-bit, but that should’nt be the culprit, or?



Try in private mode, with no extensions?

no change, I tried disabling the extensions 1 by 1, at first it seems to work and then it doesn’t

it’s really unpredictable

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.