Videos won't play (Truth Social, Rumble, maybe more...)

Ok, I’m thinking Brave must have done a recent update. My version is 1.48.158. Have a Windows 10 64-bit rig.

Rumble videos will not play. Tested further, found out Truth Social videos will not play either. Amazingly enough seems fine on Youtube. I get a constant “Loading” message, but NEVER plays. Makes no difference whether signed in or not on Rumble. Worked earlier today, so something very recent occurred. Tried disabling the few extensions I have, no change.

I have tested on Firefox, Chrome, & Edge… everything plays fine on those browsers.

I love Brave, but am somewhat avid with Rumble viewing. I’d much rather not have to use two browsers just to watch certain videos.

Please help. Thanks!!

PS. I just set Autoplay to disable. Now I have to click TWICE to play, but at least it works. C’mon… really???


i can confirm that i have the same issues. yesterday all worked fine
until this morning update
im now on `Version 1.48.158 Chromium: 110.0.5481.77 (Official Build) (64-bit)

running on the latest linux mint os

1 Like

The same problems are happening with the social site. Links are not displaying properly. Links display perfectly in Safari. Please fix soon so I can switch back to Brave. Thx.
Using iPhone SE (2nd Gen) and the latest Brave browser.

Yep same thing here, noticed Rumble videos not playing, other browsers are fine.
Galaxy Tab S7
Brave Ver 1.48.160 Chromium 110.0.5481.77

Same here. YouTube works but nothing else.

Same here. Rumble works on Vivaldi but not Brave. Brave Version 1.48.158 Chromium: 110.0.5481.77 (Official Build)(64-bit). I’m running mxlinux 21.3

Obviously it isn’t just me then. Same problem.

Yes, I am too. It only shows loading. I can play on Chrome. It’s frustrating as I don’t want to use that browser.

@fanboynz confirmed this myself. If I leave Shields on and go to click on a video, it gets stuck on Loading as you can see below:

If I turn off Autoplay in my settings, then it will work. But as OP mentioned in their edit, means you have to click on the player and then hit Play again.

The other option is to turn off Shields. With Shields off, it will play an ad and then plays the content immediately after.

I’m not sure where the interactions are going wrong, but it seems with autoplay and Shields enabled, it doesn’t successfully skip the ad and go to content. It just freezes with it stuck trying to show the ad but Brave not allowing it. Yet somehow, turning off Autoplay kind of fixes this partially.

No errors show in Dev Tools or anything.

1 Like

Same build here too… 110.0.5481.77. Looks like we’re not the only ones with this issue. Hopefully Brave will resolve.

I have not changed anything on my computer and for the last 2 days I have the same as you do. I can load the Rumble videos but all of them stay loading on black screen and nothing else happens. I sent this information to Rumble support and through Truth Social and no one replies to me. So, what do we do? I checked Down Detector doc Com and they have a lot of Rumble users with the same issues and their comments including mine are there. Any suggestions, please? Thanks.

You can turn the auto-play feature to ‘off’. I found the directions on another thread… kinda buried in the settings. Requires an extra click to play the videos, but at least they now play in Brave… which is an improvement.

We wait for Fanboynz to check it out and the Brave team to make adjustments to the browser.

Until then, either have to turn off Shields to allow ads -or- while on the site click on the lock icon on the Search bar → Site settings → change Autoplay to Block. This will change it for the site and then will let you play by clicking video player twice (once to bypass ad and load video, once to play the video).

1 Like

I’m kind of slow on this tech issues, I’ll try to find all your places on settings and see what happens and let you know. Thanks.

Oh my, can’t find that ‘auto-play’ on the settings… I’m 65 and not too computer wise, please, help me further. Thanks. :face_exhaling:

From here?

Went to wrong thing. So back when you’re visiting the website, on the left side of Search Bar, you’ll see a lock icon.
Photos 2_15_2023 12_46_30

Click it, then Site Settings.
Photos 2_15_2023 12_47_22

Autoplay will appear on the top.

This is the shortcut I’m providing. And it’s how you change it just for that one site, without having to make changes to all websites.

I already have allow there. I hope Rumble and Brave get to us to fix this. Thanks.

1 Like

You need to change the auto-play setting to BLOCK.

1 Like

I’ve opened an issue for this for our developers to review: