Video sites not working after update

Since the last browser update, I am having issues with streaming sites - netflix, youtube, hulu, and disney+ will not load video. the pages themself will load, but video gets a spinning wheel of doom and never loads properly.

How can this issue be reproduced?

  1. try watching videos on any of the mentioned sites?

Expected result:
page will load, video will not

Brave Version( check About Brave):
Version 1.34.81 Chromium: 97.0.4692.99 (Official Build) (arm64)

@critter have you modified any of your Shield settings? In particular, do you have “Scripts Blocked” turned on? I’m asking as it sounds similar to some issues when people increase the level of Shield and stray from the default settings.

This may not be the issue but wanted to tackle a simple possibility first.

1 Like

Double checking but I don’t believe so; I hadn’t changed any settings before or after the most recent update.

scripts blocked is OFF, and i briefly experimented with turning Shield completely off - no change

@critter I was hoping maybe something that quick and simple. I haven’t really had issues on my Windows PC version, but not sure if that’s a fair comparison since you’re on Mac.

The only other things I kind of would suggest is simple clearing of Cookies and making sure things like Javascript is turned on. Also just trying to think back if you’ve recently added any Extensions to Brave that might be causing an interference. Again, all of those are random things that are kind of common sense.

Guess let’s tag @Mattches and hope they can swing by when they get back on shift.

@critter,
Can you tell me what version of macOS you’re using at this time? Additionally, can you tell me:

  • If you visit any of these sites in a Private browsing window, do you get the same results?
  • Do you have any extensions installed at this time?
  • Can you confirm that these sites do work in other browsers?

I’ll have to get back home to be certain; I’m one macos update behind current

  • private browsing was same result
  • I have EFFs privacy badger installed, no other extensions
  • confirmed that Netflix, YouTube, and Disney+ worked when I fired up chrome

@critter,
Can you check and see if you have Google Widevine enabled in the browser? Settings --> Extensions --> Widevine:

I’m not convinced this is the issue, given that typically if Widevine needs to be enabled, it will stop and alert you before you attempt to stream anything. But it’s worth taking a look at.

Widevine is currently enabled, I’ll disable and try again.
Also macOS v11.2.3 big sur

What error message is being showed when trying to playback? Try disabling widevine, then restart the browser, then re-enable widevine. @critter

There’s been no error messages, just an ever turning wheel of doom. YouTube will sometimes, after a few minutes, display “if playback does not resume try reloading the page” in the background.
Can try the widevine when I get home and report back.

Would also try in private window mode

@critter,
Can you please try disabling your extensions and test to see if this makes any difference?

No change - in my own testing, the only things that have changed this (temporarily) is rebooting my computer or restarting brave, but it only fixes this issue for a day at most.

Last test of this nature to try here — can you please try creating a new temp. browser profile and see if you get the same results when using this profile? Please ensure that you only have the one browser window using the new profile open when performing this test.

Testing that today and tomorrow

this doesn’t seem to be more than temporary fix as well.
new possible connections - video stops working after closing laptop or putting computer to sleep; ie when the computer or Brave is restarted, things will play until the next time computer sleeps, and when computer wakes up again the videos will no longer play.

Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

still no change after disabling hardware acceleration - when i restart brave or computer, video playback works; after computer sleeps, playback no longer works

I know that it may seem silly since you’ve already described the issue clearly, but is there any way you would be willing to take a short screen recording of the behavior on your end?