Various bugs on Arch or Manjaro Linux

bug

#1

I’m using .56.15-3 on Manjaro Linux 18 Gnome. I’ve tried both the version in the official Manjaro repos and the version in the Arch User Repository (.56.15-1). They both are having the exact same issues:

  1. Upon opening Brave, it claims that users are “using an unsupported command-line flag --no-sandbox”. Users in the Arch User Repo have offered a temporary work around that seems extremely unsafe:
sudo sysctl kernel.unprivileged_userns_clone=1

To make it persist after reboot:

echo kernel.unprivileged_userns_clone = 1 | sudo tee /etc/sysctl.d/00-local-userns.conf

This is explicitly warned against in the Arch documentation:

Unprivileged usage is disabled by default unless the kernel.unprivileged_userns_clone sysctl is set to 1 , since it greatly increases the attack surface for local privilege escalation.

  1. Brave complains that it is not the default browser, even when it is. Always.

  2. Brave’s Shields panel appears bugged.

  1. Brave opens up a second icon in the dock if it is added to the favorites in Gnome.

#2

@asynec, sorry for the late response.
The Shields text issue is known, see this thread for more details:


For the rest, definitely don’t do the no sandbox flag. Other workarounds have worked for other users:

cc @sriram for additional help


#3

Mattches, thank you for your reply, but it doesn’t really answer my questions.

  1. I still need a solution to the Default Browser bug.

  2. my point is that that command isn’t an acceptable workaround. It reduces the security of the user’s computer and opens them up to all kinds of security issues.

https://wiki.archlinux.org/index.php/security

  1. I still need a solution for the duplicate icon in Gnome dock issue.

#4

@sriram @Mattches Still need help here. This is a significant security issue.


#5

1 - Turns out this is a known issue with Arch Linux. I’ve +1’d the following issue on your behalf:

2 - I found the original issue mentioning the workaround here:


Unfortunately that’s all I have on it right now. I’ll try and get an update on the status of this. In the meantime, feel free to +1 or leave a comment on that GH thread please do.

Sorry to just keep sending you to different GH pages but it’s all I can do with respect to the issues you’re encountering right now. As with the above issue I’ll try and get a status update on where we stand with them if possible.


#6

Thank you, Mattches. I’ll take this discussion to Github unless anyone else has any feedback.


#7

Really sorry on this. I would need some time to work on doing some research on Arch based distros. Its quite challenging and right now held up with other things. But we’ll find a solution soon for sure .