Brave browser will not start in Red Hat v8.6 aarch64

Description of the issue:
How can this issue be reproduced?

  1. Brave browser brave-browser-1.56.14-1.aarch64 installed from Brave website
  2. When the browser is launched in Gnome it does not open a window
  3. If it is launched in the CLI it gives the error line 48: 8899 Trace/breakpoint trap (core dumped) “$HERE/brave” “$@”
  4. brave-browser-nightly-1.58.49-1.aarch64 behaves the same way

Expected result:
The browser should open a window

Brave Version( check About Brave):
Unable to check via GUI. Versions tested brave-browser-1.56.14-1.aarch64 and brave-browser-nightly-1.58.49-1.aarch64

Additional Information:

Does anyone have any ideas about this issue please?

@RonCarroll sorry been going unanswered here. I know I had missed it somehow and guessing support has too. I’m going to tag in @Mattches on this in hopes he might be able to ask more questions and try to better assist. I know nothing about Linux and wouldn’t know where to begin necessarily.

Can you please try downloading/installing the latest version of the browser (v1.57.47 at the time of writing this) and tell me if you are still seeing the same behavior?

Thanks, I will try that and report back.

I downloaded and installed the current version and now the behavior has changed in the CLI but not the GUI.
For background we a a lab environment and all of our servers run as root users.

The CLI now returns a useful error that it’s not allowed to run as root without the --no-sandbox argument. Adding the argument allows the browser to launch from the Terminal CLI however it does give an unsupported command-line flag warning. I haven’t found a way to modify the .desktop file that allows it to launch with the --no-sandbox argument.

I managed to get it to launch in RHEL9.0 Gnome. In RHEL 8.6 it has the same error as previously. In RHEL 9.2 it launches but doesn’t exit cleanly leaving the tab with a spinner next to the activities tab.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.