Unwanted emails with ads on gmail

I am getting unwanted emails marked “Ad” on gmail with Shield set at aggressive. I just got a new MacAir and this was not happening with the old one.


Can you check Brave Beta? https://brave.com/download-beta/ some incoming changes, where we’re blocking standard will block more.

Thanks Ryan. I downloaded beta but still getting ads. Any other suggestions?


Screenshot of gmail ads? and which part of gmail?

@fanboynz think example is like from my alt gmail account when I have Shields off:

You’ll see on top and bottom were ads that’s hidden as emails.

I just enabled Shields and even then, it still seems to have shown on that:

On alt account, seems to only show under Promotions part. I can’t seem to find anything with ads on my main Gmail. But I don’t have Promotions on main gmail account either. So not sure how/why.

Try testing this in brave://adblock


Browse gmail, do stuff see if it breaks anything etc

Doesn’t seem to do anything.


(I really wish I could remember what all those custom filters were for, lol)

If there anything I can grab for you on that which might help or are you able to see it all from an alt account yourself?

For what it’s worth, this is what I see if I Inspect the page.

How about ||mail.google.com/mail/u/2/?ui=*gmail.pinto-server

That did nothing. However, I looked closer and realized site settings had changed. My global settings have been on Strict and all for adblocking, but somehow it changed on Gmail. Once I switched back to Aggressively block trackers & ads, it removes them.

So that toggle makes the big difference.

@Bonnais you may need to check the same thing for yours. Make sure your site version is set for it. And not sure if it matters, but you may need to enable some of the content filters which you can get at brave://settings/shields/filters.


I’m unable to see the gmail ads now, unsure if its gmail or filter related

Mine looks like Stephen Ray’s with Ad in a square. On promotions and social.

Sorry but I’m a bit of a computer dunce. I looked at mail.google.com and didn’t see anything like that. Under Brave settings I have aggressively blocked. I had Block scripts on but think it prevented me from doing something, don’t remember if it was Duolingo or something in ProtonMail. Anyway, if you have the patience and can explain in baby steps what to do I would appreciate it.


First thing I’m going to do is make sure to differentiate between site settings and global settings for Shields.


This means will activate for most sites you go to. That’s what you get when you go to SettingsShields or where you can just type brave://settings/shields in your address bar. It will pull you to screen in my screenshot below. Settings ideally will look like you see:

On that bottom of that menu, you’ll see Content Filtering. Click on that. Then select the choices you see in the screenshot below:


This should have you using the most efficient blockers in general.

Local/Site Settings.

You’ll notice on your address bar, there are two symbols. image

The lion is your Shields and the triangle is Rewards. We can ignore the triangle for this. When you click on the lion, it shows Shields settings as well. However, this is your preference for the particular site you’re at. In other words, you can override your global/default settings.

So what I shared earlier is when I was able to replicate your issue, I had accidentally changed my settings for Gmail only.

Anyway, when you click on the lion, it will look something like below:

You’ll want to make sure that they are the same as your global settings, which is also what you can see pictured in my screenshot.

If all those settings are in place, you should see absolutely no ads on 99.9% of the sites you go to. And definitely shouldn’t be seeing the Gmail ads.

Stephen Ray,

Thanks so much for your help. What I see is not exactly what you see. I took photos of what I see, hopefully you can read them. If you can read it, please let me know if I have it right. My original reply was returned because I put all 8 in one email therefore I’ll sent you 4 at a time. If it’s too much trouble I understand.



IMG_2862 (1).JPG

IMG_2862 (1).JPG


The other 4.






No new ads this morning! Usually I have 4 every time I check my gmail. Yea!


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.