Unreadable super-blurry window

#1

Hi, I literally just tried Brave today for the first time and it seemed really good right up until the window goes blurry and keeps on going blurry continuously.

This does not happen with any other app on my pc at all. I tried disabling hardware acceleration and that fixes it but I don’t want that disabled because after 5 mins of scrolling on twitter or tumblr and the browser starts getting all jerky and stuttery. I have spent the last 2 hours trawling the internet for fixes and have tried many suggestions like DPI settings in the compatibility tab of the shortcut, windows display scaling etc etc and nothing has made any difference at all.

I just uninstalled chrome to use this (it never happened in chrome at all) and am already regretting it…

I am using windows 10 1809, CPU is a 6600k, GPU is Nvidia 980ti. I have 24gb of ram installed and the OS is on a Corsair force MP510 980gb M.2 SSD.

Latest Nvidia drivers are installed.

Like I said, everything else runs perfectly with zero blurriness, this includes firefox, chrome and every other app on my entire PC.

I hope there is a fix for this so I can stick with Brave instead of going back to chrome…

#2

@Mattches is your chance at a solution

1 Like
#3

@Dgenies thanks for the hype :slight_smile:
@illogik,
Display issues like this are usually related to conflicts with Hardware Acceleration (though not always). Try disabling this feature and see if it resolves your issue. You can find this setting in
Settings --> Advanced --> System --> Hardware Acceleration

Let me know what you find out.

#4

@Mattches

:laughing::laughing:

1 Like
#5

Well I have found out what is causing this blurring and have got rid of it.

What I did was create a 3D profile for Brave in the Nvidia control panel’s 3D settings and disabled everything. Blurring is gone. I then enabled everything one setting at a time until the blurring returned and it turns out the culprit is: Antialiasing - FXAA.

Apparently this setting enables and disables blurring in the Brave window as well as Antialiasing FXAA.

I should probably have this stuff set to off by default but I play a lot of games so have everything set to max and if any game doesn’t like a setting I create a profile for that game. Also the fact that it doesn’t happen with any other browser or app, ever, kinda points to the issue being with Brave :stuck_out_tongue:

2 Likes
#6

You sir, are a hero! Was having the same problem and disabling Antialiasing in the NVidia control panel also fixed it for me.