Unable to watch videos on local live TV streaming site


#1

Description of the issue:
I have an account provided to me by the local TV broadcaster, that allows me to stream TV live, and selected shows within 24 hours after they’ve aired. I use this site daily on weekdays at least once, and for the past 2 months have had to start up chrome to watch the show, just to close it when finished and go back to Brave.
Steps to Reproduce (add as many as necessary):

  1. Navigate to https://now.dstv.com/ (Instantly says: “Please upgrade your browser. An upgraded browser will make your computer safer, and improve your web experience. DStv Now works best in the latest versions of Chrome or Firefox.”

  2. Login to view live TV

  3. Stream player says a similar error, and doesn’t allow operation:
    “Cannot play video as your browser or operating system is not supported…”

Actual Result (gifs and screenshots are welcome!):

Expected result:
Being able to watch my shows
Reproduces how often:
100% (Even back on 0.25.x)
Brave Version(about:brave):

Reproducible on current live release (yes/no):
Yes
Additional Information:
You will probably need an account to log in to the site, which will make it really extra hard to test or apply a fix for this. Im willing to help with anything i can offer though.


#2

@Jeandre,
This may be related to Widevine. Do you see a notification in the URL bar when you visit the website saying that the Widevine plugin isn’t installed? If so, activate it and you should be good to go.

If you don’t see that notification, visit the website, open your Shields panel and turn Shields off and see if the site loads. If it does, that means that Brave is blocking some functionality on the website that blocks your ability to stream. If that’s the case let me know and we can narrow down what the cause is.


#3

I did not get a notification for Widevine. I tried just now without Brave Shields on, and even enabled flash just to rule that out too, but both still resulted in the error.


#4

Sorry i’m not sure if i tagged your post in my previous reply. Am new to this forum.


#5

No problem at all. I’m looking into this right now for you. Appreciate your patience!


#6

Sorry for the late response.
Whether you have an account or not, will you try navigation to https://netflix.com? Once there, check the URL bar to see if you’ve been prompted to install Widevine. I just read a report from a user saying that they couldn’t get Youtube TV to work because of Widevine and this was the fix they used to initiate the prompt to install Widevine.

Let me know what you find out.


#7

It worked :smiley: Thank you very much


#8

You’re very welcome!
Glad it worked for someone else too, may help solve additional Widevine issues.
Thank you for reporting!


#9