Unable to uninstall Brave


I am unable to uninstall Brave, because when the browser opens it creates a process that cannot be killed. When opening the browser, it just says connecting…
If I close Brave and reopen it, then an additional process gets created.
These processes use about 13700k or memory.
In settings, Brave reports that it is up-to-date, despite being unable to connect to internet or even the router.

How can I uninstall Brave without having it hang by the browser’s opening during the uninstall?

Description of the issue:
How can this issue be reproduced?

Expected result:

Brave Version( check About Brave):

Additional Information:

USE CCLEANER to clean the PC in an advanced way, then uninstall BRAVE.

I can’t even get it to run
Firefox will have to do

This doesn’t work, because the uninstall process launches Brave, at which point Brave creates a process that can’t be killed, clogging the uninstall.

@JohnB3.,

  1. What is the name of the process that cannot be killed?
  2. Are you using the built-in Windows Add/Remove programs option? If so, ensure that you also check the Remove associated data box that appears.
  3. Windows 7? 10?

This is Windows 7. I am using the Windows Add/Remove programs option.
The problem is to do the uninstall it is opening Brave.
The process that cannot be killed is brave.exe.
The browser is hanging for some unknown reason, unable to access internet.

@JohnB3 have you tried uninstalling after restarting your machine?

1 Like

Yes. The same problem. After restarting it again hangs on uninstall.
I tried Revo uninstaller, which seems to have gotten stuck partway through. Now Brave is not listed as an intalled program, and I don’t see files under Program Files or Program Files (x86), but the installer is not working.
Update: I tried the old installer from Feb. It installed, but it did so very quickly, looks like it was using the old files, and now again Brave is unable to connect to Internet.

I tried deleting the files manually, then reinstalling. The old installer from February does a download, but the same problem happens again, only this time it doesn’t say ‘connecting…’

JohnB3, did you ever figure out a solution? I’m having the same problem. Can’t seem to get past it.