[Solved] Can't Open Brave, Can't End Brave.exe which is disabled, Can't Uninstall Brave

Description of the issue:
Last night brave decided to stop working. It was the end of the night so I just decided to shut everything down and go to sleep. Today when I started my machine up, I couldn’t get brave to get going at all. I click on the icon and the little blue spinning thing pops up for a second, and then its gone and brave is not open. In Task Manager I can see it pop up as well, but it just disappears.
So far I have tried:

  1. Shutting down and restarting my computer
  2. Ending the process via Task manager - No Brave processes are running
  3. Ending brave.exe via detail page in task manager running as admin “Operation could not be completed. Access Denied” note: It is labeled as disabled here.
  4. TaskKill from command prompt only yields “There is no running instance of the task.” even though it is clearly displayed in the task list.
  5. Uninstall the program “Please Close ALL Brave Windows and try again”
  6. Re-installing from the website, which says it is installed but nothing has changed.

Operating System and Brave Version(See the About Brave page in the main menu):
I’m running Windows 10
This is the newest download off the brave website from 2 days ago.

Additional Information:

Any assistance would be greatly appreciated

Just figured it out.
Mcafee wasn’t uninstalled completely. After running the McAfee Consumer Product Removal Tool, it was able to get all the Mcafee programs that weren’t able to be removed manually, and stopped all of these shenanigans.