Unable to swap between accounts - specific issue encountered by connecting everlend.finance

Description of the issue:

Using the new Brave Wallet, just connected everlend.finance and was forced to create a new account. Once connected from everland.finance, the new account has no balance. There doesn’t seem to be a way to transfer balances from my main account to the new account created to connect to everland.finance.

How can this issue be reproduced?

Go to everland.finance
Launch app
Connect Brave wallet
Brave wallet opens and auto-creates a new solana account

Brave Version (check About Brave):


Version 1.43.93 Chromium: 105.0.5195.127 (Official Build) (x86_64)

Additional Information:

When trying to “send” to the new account, Brave knows that you’re sending to yourself and a warning appears and doesn’t allow the sending.

Just a FYI, you’re using an outdated version. Current version of Brave is 1.44.05.

I wouldn’t think this is the case. There should have been a way to log in or connect an existing account. Main issue is I haven’t done anything with it all and wasn’t about to go try it. I’m going to tag @jleonard and @DouglasHDaniel to see if either can stop by to help. Hopefully they can check in tomorrow.

@dsottimano

This should be fixed on new releases. Just tried it on 1.44 and 1.46 and it worked fine and i connected a solana account that I already had created. Let me know if updating your browser, fixes the issue.

Also I agree that the send experience between accounts could be clearer. added an issue here to investigate https://github.com/brave/brave-browser/issues/25835

Thanks,

Hubert

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.