"Unable to connect to the Internet" on Brave Installer 1.0.0

Description of the issue:
Unable to install the latest production version of Brave browser (1.0.0) due to installer error: Unable to connect to the Internet. If you use a firewall, please whitelist BraveUpdate.exe

How can this issue be reproduced?

  1. Download latest installer from https://brave.com/download
  2. Run installer
  3. Installer fails to connect to internet

Additional information:
Whitelisting the executable did not help. I also disabled Windows Firewall to see if that was an issue, still did not resolve.

Downloading Brave’s standalone installer from GitHub allowed me to install without issue. Hopefully this will help those just wanting to get Brave installed.

Links: x64 Standalone | x32 Standalone | Brave 1.0.0 GitHub Release Page

1 Like


DNS is correctly resolving for updates.bravesoftware.com which also responds to PING. That host maps to f2.shared.global.fastly.net (for me) and (as of this writing) Fastly is not reporting any outages.

Try disabling your AV. I allowed it through the firewall, ran in compatibility mode and finally disabled the built in Windows 10 AV which allowed it to install.

Here to add some more.

This is a fresh install of Windows 10. Tried a few times, all failures. Tried with firewall off, as well as active. Ran as administrator and as normal.

I am also able to ping the updates page and it responds as it did for samureiser.

I’m in the US.

Having exactly the same problems here, in the UK

Same here, Unable to connect to the internet, on multiple computers and different internet connections.

Same here in the Netherlands

Also happening here in Luxembourg

FYI you access the standalone installers here: https://github.com/brave/brave-browser/releases/tag/v1.0.0

1 Like

Same in Spain… It says there’s a problem with the firewall…

Finally got it to work using this offline installer specifically:


Make sure you delete all folders created by prior install attempts and end all Brave Installer tasks in task manager, prior to running installer.

As per my suggested workaround and @sevilnatas / @Taomyn mentioned, using the offline installers seem to fix this issue.

x64 Standalone | x32 Standalone | GitHub Release Page

In czech republic it does not work too, It is a shame when you propagate this product and installation does not work.

Exactly the same issues here.

Same here, it’s showing the following text:

An error occurred while checking for updates: Unable to connect to the Internet. If you use a firewall, please whitelist BraveUpdate.exe. (error code 7: 0x800421F4 – system level).

Learn more

Version 1.0.0 Chromium: 78.0.3904.97 (Official Build) (64-bit)

Furthermore, the non-standalone installer is also not able to download and install Brave.

It’s possible many of these errors were due to an outage we had on the updates server: Brave update seems to have a problem. Please attempt to install again, as the outage has been resolved.

It should also be noted that the standalone installers are named such as: BraveBrowserStandaloneSetup.exe

It is not advised to install the executable directly, named such as: brave_installer-x64.exe

1 Like

Great, it is working now, but when I try create a wallet it writes an error: “Wallet creation failed plese check your internet connection”. It looks like you must work harder in order to be best :slight_smile:

This is strange, the standalone installer doesn’t need to download anything. It may look like it needs to connect to the internet but it actually doesn’t. Everything is already included in the executable.

Can you mention specifically which installer you tried?

brave is total garbage…you get it working with the firewall then it does nothing but frreez up…im getting rid of it…its rubbish,not worth the effort.


Thanks for the reply. I was using the standalone installer.

I think it’s working now though. About Brave now correctly shows that Brave is up to date, instead of trying to connect and check for a new version. I think the online installers are also working properly now.

This topic was automatically closed after 30 days. New replies are no longer allowed.