Unable to access specific site on mobile

Description of the issue:
I’am trying to access a website (globo.com) from my brave mobile browser and I’m unable to

Steps to Reproduce (add as many as necessary):

  1. Access Brave Mobile
  2. Type globo.com
  3. This site can’t be reached

Actual Result (gifs and screenshots are welcome!):

Expected result:
Access the Globo website

Reproduces how often:
Always

Brave Version(See the About Brave page in Settings):
Brave 1.0.95, Chromium 74.0.3729.157

Mobile Device details
OnePlus 5T

Android/iOS Version
Android 9 (Pie)

Additional Information:
It does not seems like a DNS issue. I’ve connected to three differents wifi, used a VPN and also with my mobile carrier and it’s always the same result. I’ve also disabled Brave Shield and still the same thing. If I use Chrome mobile it works fine, this just happens with Brave on my mobile phone (desktop works fine too) and only with globo.com

Thanks for reaching out.

I just checked globo.com and it opened just fine. It could be that globo.com server had issues.

Brave v 1.0.97 on Samsung s7

@lucasfcunha Could you recheck and let us know?

It’s definitely something related to brave. It has been going for more than 3 days now and I can access just fine with Chrome:

On Brave;

On Chrome

Both accessed just now and on Chrome everything is fine and Brave I cannot access it.

I see what the issue is.

It is a site issue. In Brave you try to open the page by going https://globo.com. In Chrome https://www.globo.com.

To resolve the issue just open https://www.globo.com in Brave. Works for me.

BTW https://globo.com fails to open for me too.

@lucasfcunha please do you have any important thing save to your brave cause I want to suggest an app clear data from phone app settings.

You could also go to settings and clear browser data

That worked. I’m stupid.

I’am just used to type website.com. I guess that chrome already had the right address for the website while brave did not.

Thanks for the help guys and sorry for wasting your time, never stopped to look at the url since I’ve been doing that for years (just typing globo.com).

I think it is a cache issue or a cookie issue. I didn’t have that problem on my end brave redirected to the www version