Unable to access Firebase in Brave

Description of the issue:
I recently moved to the Brave browser and everything has been smooth except this. I use Firebase at work but I am not able to use the site, I get a cookie mismatch error. I’ve tried clearing cookies, logging out and logging back in but it doesnt work.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Launch browser, navigate to console.firebase.google.com

Actual Result (gifs and screenshots are welcome!):

Expected result:
Firebase console opens and is usable.

Reproduces how often:
Every time.

Operating System and Brave Version(See the About Brave page in the main menu):
MacOS Mojave 10.14.5 & Brave 0.66.99

Additional Information:

What sheild settings are enabled? does it work with Sheilds disabled?

I created a test database without issue here, though directions to replicate any issues would help

Yup, I have tried it with Shields disabled as well. It keeps giving the same error.

I was using Firefox before this so when I installed Brave, I migrated all the settings, cookies included, to Brave. Every other Google product (Analytics, Mail etc) works fine except Firebase.

Could you try on a new profile (maybe Brave Nightly?) see if that changes things (without importing any settings over).

So it works in the Nightly version. Something must be wrong with my cookies :confused:

Could try clearing your cookies/cache and retesting

1 Like

Well, it works now. Earlier, I searched for terms like google, firebase etc and deleted those cookies. Right now I did a full clear and it works :frowning:

Clearly something was going wrong with cookie migration.

Thank you for your help!

This topic was automatically closed after 30 days. New replies are no longer allowed.