https://accounts.google.com/CookieMismatch?


#1

I’m using Brave 0.56.15 on an iMac (OS 10.12.6). Any attempt to sign in to Google sites fails. I have followed the advice in earlier posts to allow cookies, clear data etc. and have also set three Google sites as being allowed to use cookies. No luck so far. I guess that the next step might be to uninstall Brave and reinstall it? Any views?

Without wishing to to be unfair to Brave I would add that there are no problems using Cliqz to login to Google.


#2

@Charleswj,
I know you metioned that you’ve already tried previous advice, but we’re going to try again. Try the following:

  1. Navigate to one of your google accounts (lets say gmail for example).
  2. Open the Shields panel and set cookie control to Allow all cookies
  3. Now, in the Shields panel, click on Global Shields Settings at the bottom (alternatively you can go to Settings -->Global Shields Defaults)
  4. Set the Cookie Control option here to Allow all cookies as well
  5. Now, navigate back to gmail and login
  6. You should be able to authenticate without issue
  7. Once done, you may re-enable your Shields settings the way you’d like (and still be able to log in and/or remain logged in).
    If the above doesn’t work, try the same steps with all Shields down when you navigate to Gmail.

Let me know if this works for you.


#3

I followed your suggestions for which many thanks. Tried to login to Gmail and was refused as before. Cookie management is not my thing so I’ve always used a cookie manager. And I wondered if it was causing the problem.

I run ‘Cookie’ <https://cookie5app.com/ > which has a ‘Pause’ control. I paused ‘Cookie’ and tried again. Success! Now I can log in to Google with ‘Cookie’ running and Shields up as before. I have no idea why this worked, it’s a trick to remember though.


#4

That happens if you import you data /w cookies from another browser. So you must delete the cookies for that particular site and try logging in again,


#5

I am using

Version 0.57.18 Chromium: 71.0.3578.80 (Official Build) (64-bit)

on Windows 10, and I followed the instructions above to allow all cookies. I also cleared all cached cookies. I can get to my Google Drive, but I cannot get to GMail or the Calendar. Is there another way to ensure cookies are deleted for Google in Brave? Any other suggestions?


#6

@nhelman64,
Did you try allowing them in Global Shields Settings as well or just in the Shields panel?


#7

I did that, and it hadn’t been allowing me into gmail or the calendar. I tried it just now and it DID allow me into both gmail and the calendar. Not sure what the difference is, but it’s working now.


#8