Twitter log-in pop-up

When I scroll down someone’s twitter profile, a pop-up requires to log-in. The only way I know to remove this is by refreshing the page. Tell me, Brave, how do I use twitter without log-in pop-up?

Have you tried turning off the shields? :man_shrugging:

Yes, I have. I have also tried other browsers, such as Vivaldi and Edge. The issue remains.

This is a feature of Twitter, not something controlled by the browser. Seeing this behavior in other browsers shows that.

Cookie messages are also not controlled by a browser. Yet, I can use Brave to remove the chrome store cookie warning. Yes, sure, I can add sites to Brave’s ‘sites that can never use cookies’. And now I want Brave to have an option that removes the log-in pop-up.

One thing you can try is right-clicking on the message, then selecting Brave —> Block element.

1 Like

Except that the pop-up is hidden, it’s the same result

@jordy I just went to the same URL you show and I can view everything with no issue.

Then I scroll through. All I see is a banner on the bottom asking me to Log In or Sign Up but I can ignore that. Then the thing on the top right giving option to sign up or log in. But yeah, I scrolled through, watch videos, etc.

Big difference is I don’t have the Cookies thing, so I’ve likely clicked to allow it. Not sure if that might make a difference for you.

Also noticed nobody asked. What version of Brave are you using? What operating system? Are you running any extensions?

I already said it happens in other browsers too, such as Vivaldi and Edge. I have never used Edge before, and the only Edge I have is the default factory installed. I do not use Edge with extensions.
I’ve recently reset my pc. My pc runs on Windows 10 Pro.
Brave version 1.36.87.
Accepting cookies doesn’t remove the pop-up.
Disabling my VPN doesn’t remove the pop-up.
I just reckon this is not an issue which Brave can resolve.

You are correct — the issue isn’t with Brave and likely is not something we can address but I would like to confirm that.

cc @fanboynz for more information on if any solutions are possible

@Mattches Did that pop up for you though? I’m trying to figure out how I was able to view the same page they are referencing but I don’t have that popup they are showing in the screenshot. And no, I wasn’t signed in or anything.

1 Like

Twitter uses semi-random div element.

Adding the following into brave://adblock,html:style(overflow: auto !important; position: initial !important;)


  • Navigating off the page will ask for a login
  • There could be many false positives caused by this (login buttons/windows not showing etc)
  • These elements will change over time

This happens after adding those three lines to Brave://adblock
Trackers & ads blocking enabled:

Trackers & ads blocking disabled:

Seems good then? Could block the bottom 2 bars also…

No. My first screenshot shows the twitter page going blank. The second shows the pop-up.
I cannot continue scrolling the profile.

This topic was automatically closed after 30 days. New replies are no longer allowed.