Disable Google login popup

I recently started getting many pop-ups as I’m browsing different sites asking if I’d like to sign in with my Google ID. This is a big nuisance because I’m having to close this pop up over and over as I browse different sites. I don’t want to log in to every site I visit, and I don’t want to log in with Google.

I do usually keep my Gmail open in a pinned tab, which I’m guessing is why this is happening. But I’d like to know if there’s a way to disable these obnoxious pop-ups while still keeping my Gmail pinned. This seems to be a new issue as of the past few weeks, so I’m wondering if it’s related to a recent Brave update.

Thanks for any suggestions!

1 Like

Hi @philippe,
What version of Brave are you using?
What OS/device are you on?
Can you give some example sites that show these pop ups?

Hi @Aa-ron,
I had the same problem with this pop-up. It’s annoying in this way.
I am using Brave version 1.16.72 Chromium: 86.0.4240.183 (Official Build) (64-bit) on POP! _OS 20.10.
I get it at visiting news websites, Reddit, …
I know this pop-up helps me log in faster but I don’t need it. Do I have a way to ‘mark as notification’ or hide it in default?
Thanks for your any suggestion.

Can you try disable Allow Google login button... which can be found under Settings > Social Media Blocking and see if it can solve your issue, @minikni @philippe ?

1 Like

Thank you @eljuno,
It worked.

Wish you well and keep do good.

Yes, that seemed to do the trick. Thanks!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.