Annoying login with google popup

Login with Google popup:
How can this issue be reproduced?

  1. disable Allow Google login buttons on third party sites
  2. Go to Newegg.ca and browse around without being logged in
    3 .

Expected result:
You should not see the Login with Google popup in the upper right corner of the browser but you do!

Brave Version( check About Brave):

Version 1.46.110 Chromium: 107.0.5304.110

Additional Information:

This just recently started happening. I never saw this behavior before. Windows 10. Happening on multiple websites. I click on X in the popup it disappears. I close that tab and go back to that site later on and the same thing happens. I see the darn popup again!

2022-11-23_105358

I removed my two Gmail accounts that showed up in the popup window above.

3 Likes

Hello there @fedup, please do the following to see if the pop up is no longer prompted when loading those sites: Go to brave://settings/privacy > Use Google services for push messaging > Disable it.

Once its disabled try again to see if the pop-up shows again.

Be waiting for your response.

1 Like

@Kevin_cc

No difference with that option disabled and a relaunch of brave. I went to Newegg.ca and went browsing and got the popup.

I have that push option enabled to get YouTube notifications. Again this only started happening on this site and slickdeals.net recently.

1 Like

Posting this as I doubt anyone from Brave officially will comment on this issue.

Apparently Brave will not block this pop up/down for Login With Google and it has nothing to do with the “Allow Google login buttons on third party sites”. I have been told by someone on Brave’s subreddit that the Brave Setting is only for the way Brave treats Google login cookies.

It seems that these annoying pop ups will have to be put up with until Brave Devs decide to do something about them. No holding my breath on that happening anytime soon.

If you add into brave://adblock (custom filter) ||accounts.google.com/gsi/client$script,third-party

Does that help?

I have tried that and so far neither Newegg.ca nor slickdeals.net is having that popup showing up. Hopefully, that fixes it for good.

Thanks

I just checked https://www.newegg.ca/ this removes the google popup.