Twitter links return an error when clicked on

Links in my email to Twitter for Daily Briefing return an Error saying " Something is technically wrong." “Thanks for noticing—we’re going to fix it up and have things back to normal soon.” " * © 2011 Twitter

This has been going on since my last Brave Update. I’ve checked all settings and can’t find anything causing it.

I’ve checked the same link in Chrome and it works fine, no error message. So I don’t know where to go from here. I’ve even deleted and reinstalled Brave and that didn’t make any difference. Any suggestions, or possible settings that may have gotten changed in the update that would fix this problem would be very much appreciated.

The fact that the problem only presents when used in Brave Browser leads me to believe that the issue is with Brave and not Twitter.

@Allan7413,
Thank you for reporting.
Testing on my end, I’m able to click Twitter links from my email and have them open in Brave without any issue using the following steps:

  1. Open my email account in Brave
  2. Open an email containing a link to a Twitter account
  3. Click on the link
  4. Observe the Twitter link opening normally

To clarify, are you using an email client in Brave, or is it an external email client installed on your PC where you are clicking the links?

Thanks for the reply.
I am using Proton Mail which I have also tested on Chrome where the links open normally as they do with your Brave Browser. I have to think it’s a setting that got changed when I installed the latest update.

@Allan7413,
But you are logging into Proton Mail in the browser — as opposed to using the desktop application?

Yes, the Protonmail is a website, not a stand alone app. You can see it at https://mail.proton.me

The same is happening to me as well, I’m not using any application or external website. I use my Gmail on the Gmail website whenever I click a link on my Social updates.
It seems that the redirect link isn’t loading well. When I use the exact same link on chrome it works flawlessly.

I am having this issue as well. Using the Gmail app for Gmail on Android. It opens my weblinks in Brave.

I have the same issue using GMail in Brave.

Same problem here for weeks with Thunderbird. Copying the link into Chrome or Firefox works fine.

Hello,
Thank you all for reaching out with this rather strange issue.
I’ve reached out to the team with this to see if anyone has any ideas or if they can reproduce, since I cannot reproduce on my end on Windows or macOS systems — tested using both gmail and protonmail. Twitter links seem to be opening just fine for me.

Can everyone here experiencing this please provide for me the:

  • Brave version you’re using (Menu --> About brave)
  • OS version you’re using (Win 10, 11, etc)
  • Whether or not this is a specific type of Twitter link or if it is any link. For example, if you were to receive an email with a basic link to https://twitter.com in it, would clicking it still result in this same error?

Thank you

Version of Brave:
Version 1.47.186 Chromium: 109.0.5414.119 (Official Build) (64-bit)

Version of Windows: 11
Specific Twitter Link: Yes
Basic Link: No
Examples of links that fail: https://twitter.com/i/redirect?url=https%3A%2F%2Ftwitter.com%2Fbrithume%2Fstatus%2F1618714520406609921%3Fcxt%3DHBwWgsDS2fWR6vYsAAAA%26cn%3DZmxleGlibGVfcmVjcw%253D%253D%26refsrc%3Demail&t=1+1674809454707&cn=ZmxleGlibGVfcmVjcw%3D%3D&sig=bf35c1534f3eabf178a25171aca0a17ca772db94&iid=43b18e8572664bd3940e560664b027ec&uid=1046085619221331968&nid=244+272699400

Expample of links that fail: https://twitter.com/i/redirect?url=https%3A%2F%2Ftwitter.com%2FRWMaloneMD%2Fstatus%2F1618726498906804224%3Fcxt%3DHBwWgMDQvZTL7_YsAAAA%26cn%3DZmxleGlibGVfcmVjcw%253D%253D%26refsrc%3Demail&t=1+1674809454708&cn=ZmxleGlibGVfcmVjcw%3D%3D&sig=846da2d4dcd480267ea6fe343845962de464c471&iid=43b18e8572664bd3940e560664b027ec&uid=1046085619221331968&nid=244+276893704

Example of links that fail: https://twitter.com/i/redirect?url=https%3A%2F%2Ftwitter.com%2FDLoesch%2Fstatus%2F1618779610337972224%3Fcxt%3DHBwWgMC4vdPeh_csAAAA%26cn%3DZmxleGlibGVfcmVjcw%253D%253D%26refsrc%3Demail&t=1+1674809454709&cn=ZmxleGlibGVfcmVjcw%3D%3D&sig=01961091f0a33ebac5d01f46b8cb028d5fa8b597&iid=43b18e8572664bd3940e560664b027ec&uid=1046085619221331968&nid=244+285282312

@Allan7413

I’m using Brave on Linux and had the same error. My solution was to drop the Brave Shields on twitter.com . The links worked after that.

Hope this helps,
Colin

That’s the secret. I dropped them for twitter.com and tried one of the links and it went right through. So I put the shields back up and got the error message again, took the shield down and again it went right through. Thanks so much. That solves it for me.

@Allan7413

I’m a first-time poster here. I’m glad it worked.

Colin

I have the same problem with links from Thunderbird. I have established it is a Brave problem as when I change my default browser to MS Edge the links work fine. So too for Firefox.
I re-set brave - so all extensions are disabled and I get the same result. Even just copying the twitter.com URL into Brave I get the same failure. I did manage to turn off the Brave shields making Twitter an exception and then Twitter worked, but I can’t find that setting anymore.

Found the culprit for me. It was Brave Shield, I turned it off for Twitter and it works perfectly now. Redirect links have no issues.

1 Like