Page not rendering correctly with current version

Description of the issue:
Twitter feed is not showing up - only clickable link to Twitter account; feed should be below this. Works on Chrome, Firefox, Safari; used to work on Brave

How can this issue be reproduced?

  1. go to
  2. see the Twitter link, Tweets by EVIndivisibles
  3. View on other browser to see what the correct UI is.

Expected result:
Should show a scrolling feed for Twitter account

Brave Version( check About Brave):
Version 1.10.97 Chromium: 83.0.4103.116 (Official Build) (64-bit)

Additional Information:
from Brave:

from Safari:
Screen Shot 2020-07-14 at 8.28.32 PM

Hi @lhartzman,
The tweets are appearing for me.
Can you share with me your Shield settings while on that site?
Can you try visiting the site in a private window - do the tweets display then?

Here are the settings in the screenshot.

I tested this, I managed to see the twitter feeds.

The only time I had issues was when I disable Twitter block in shields brave://settings/socialBlocking


I finally discovered what the problem was. It was my “fault” as it happened after I installed the DuckDuckGo extension. Once I disabled it for the site, the Twitter feed showed up.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.