Twitter is broken in Brave please help me fix it

Every time I log in it quickly flashes the login screen and then goes to my timeline but it’s just black and I have to click HOME to get the feed to show up. A ton of features are totally broken as well: Cannot report anything, cannot emoji respond to DMs, cannot follow anyone, cannot vote in a poll. When I try to do these things it shows up for a split second and then reverts back to as if I had not clicked it. This is super annoying and is making my use half of what it should be.

I have cleared cookies and I tried twitter in Firefox and all the features work there. How can I fix this? I really don’t wish to switch browsers but I use twitter all the time and I need it to work.

Thanks : (

1 Like

@Mollie

I am providing you with a lot of information. You might study the following, and find that you will try some of the settings, but not others. That is OK.

This is sort of a crash course, that gets you behind the scenery of ‘just a few settings choices’. You might skip all of it, but keep the info around, for future reference - when you are prepared to dig in and troubleshoot.

In the following settings and illustrations, some of the settings are temporarily set for difficult website connections involving a Sign-In. IF temporary, I’ll note that: (temporary).

At: brave://settings/security:

  • DISABLE: Always use secure connections (‘HTTPS Only’ toggle switch) (temporary)
  • DISABLE: Use secure DNS

I use Brave Shields v1. I think that the instructions for Brave Shields v1, are more detailed and helpful.

If you are interested in using Brave Shields v1, then in a Brave Browser > New Window, go to: brave://flags . . . and search, there, for: Enable Brave Shields

  • DISABLE: Enable Brave Shields v2
  • ENABLE: Enable Brave Shields v1

You DO NOT have to use Brave Shields v1, but the site-specific Shields v1 (Lion icon) at the right end of the Brave Browser window’s URL address field, provides panels with better control over site-specific Shields settings.

Now, check the Brave Browser Global Shields settings - in a Brave Browser > New Window, go to: brave://settings/shields

  • DISABLE: Auto-redirect AMP pages (always)
  • DISABLE: Prevent sites from fingerprinting me based on my language preferences (temporary)
  • Trackers & ads blocking: Standard (temporary - usually Aggressive)
  • Enable: Upgrade connections to HTTPS (‘HTTPS Everywhere’ toggle switch) (always)
  • Enable: Block scripts
  • Block fingerprinting (aka Fingerprinting blocking): STANDARD (temporary - usually Strict)
  • Block cookies (aka Cookie blocking): Only cross-site (always)

In Brave Browser > Settings, there are two methods for Allowing specific JavaScript sources:

1st Method for Allowing specific JavaScript sources (click the Summary button):

Summary

In a Brave Browser > New Window: brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter abs.twimg.com as the site . . . but Do Not Enable:

  • Current Private session only

Click the Add button

Repeat those steps for:

  • accounts.google.com
  • api.twitter.com
  • appleid.cdn-apple.com
  • twitter.com
  • www.twitter.com

2nd Method for Allowing specific JavaScript sources (click the Summary button):

Summary

In a Brave Browser > New Window, go to each of (you will have to copy and paste these):

  • brave://settings/content/siteDetails?site=https%3A%2F%2Fabs.twimg.com
  • brave://settings/content/siteDetails?site=https%3A%2F%2Faccounts.google.com
  • brave://settings/content/siteDetails?site=https%3A%2F%2Fapi.twitter.com
  • brave://settings/content/siteDetails?site=https%3A%2F%2Fappleid.cdn-apple.com
  • brave://settings/content/siteDetails?site=https%3A%2F%2Ftwitter.com
  • brave://settings/content/siteDetails?site=https%3A%2F%2Fwww.twitter.com

And for each, scroll down and set JavaScript to: Allow

Clearing Browsing history, Cookies, some Site data, Cache, Autofill form data:

In a Brave Browser > New Window, go to: brave://settings/clearBrowserData

For tab Advanced

  • Set: Time range:All time
  • Enable: Browsing history
  • Enable: Cookies and other site data (Signs you out of most sites)
  • Enable: Cached images and files
  • Enable: Autofill form data

Click on the ‘Clear data’ button.

(The ‘Clear data’ button also saves the selections.)

Cookies check

In a Brave Browser > New Window, go to: brave://settings/cookies and in the upper-right area of the window, enter into the Search field: twitter

Then, search down the cookies settings page and check to see if twitter shows under Sites that can never use cookies . If exists, then remove the twitter entry.

JavaScripts check

In a Brave Browser > New Window, go to: brave://settings/content/javascript and in the upper-right area of the window, enter into the Search field: twitter

Then, search down the javascripts settings page and check to see if twitter shows under Not allowed to use javascript. If exists, then remove the twitter entry.

Clearing DNS cache

Option A

In a Brave Browser > New Window, go to: brave://net-internals/#dns and click on ‘Clear host cache’

Next, go to: brave://net-internals/#sockets and click on both of the following (in succession):

  • Close idle sockets
  • Flush socket pools

Exit / Quit Brave Browser

Exit / Quit everything else and Restart your computer.

Option B

How to flush DNS cache in Windows OS: ‘https://www.wikihow.com/Flush-DNS

How to flush DNS cache in Mac OS: In a Terminal.app window, enter at the prompt:

dscacheutil -flushcache

Exit / Quit everything else and Restart your computer.

Notes re what are:

DNS cache:

Socket pool:

With pooling, instead of closing a connection after it is used, we can keep it idle while it waits to handle another request. This saves the resources required to create a new connection.

1 Like

Thank you for all of this. I did it all and none of the problems are fixed. I am now having to use another browser for twitter which is the main site I use so I am not happy. I might end up not using Brave at all anymore because of this.

I am really hoping someone, anyone replies to this again with some other suggestions.

@Mollie

In a Brave Browser > New Window, go to: brave://settings/cookies

Scroll down that settings page, to Sites that can always use cookies

Click the Add button

Enter [*.]twitter.com as the site . . . but Do Not Enable:

  • Current Private session only
  • Including third-party cookies on this site

Click the Add button

Next, go to: brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter [*.]twitter.com as the site . . . but Do Not Enable:

  • Current Private session only

Click the Add button

Did you install any Extensions. If so, then please test their possible involvement.

Disable all of them, and then Enable each Extension, one-at-a-time. You might consider, also Removing and then Re-installing them, one-at-a-time.

In a Brave Browser > New Window, go to: brave://settings/system

  • DISABLE: Use hardware acceleration when available

BTW, what are:

  • Your computing device Operating System
  • Brave Browser version numbers

1 Like

I have not installed any new extensions in over a year. I am on an HP laptop running the latest version of Windows. And Brave is version 1.40.107

I did all those things and it’s still the same. Thank you so much for the help.

1 Like

I’m using Windows 11.

1 Like

@Mollie

Thanks for the OS and BB version info.

To be clear, you have installed one or more Extensions?

Using a Brave Browser > New Private Window, please test/visit Twitter again, and report back here, any change.

Also, you might create an additional Profile for testing:

@fanboynz is a member of Brave Support, and probably can help you further.

1 Like

OK. I think that fixed it. Which might be a bummer since I think that means it’s my extensions which are things like adblocker and last pass that I need all the time. Ugh… now I guess I am going to disable each one to see… ty for this!

1 Like

To be clear I created a new profile and it works there, that’s what I was saying.

1 Like

Welp. It’s Last Pass. My password manager that I use all day every day and I need. So… now what? This is not workable either. Is this Last Pass problem or Brave? And will either work it out or do I have to leave Brave? Someone will work it out… right? I don’t know how these things work.

2 Likes

@Mollie

Take a look at 1Password:

1 Like

Is that a whole new password manager? Because I am paid ahead on Last Pass and I like it and don’t wanna switch. I might switch from Brave first tbh.

@Mollie

Meanwhile, I wonder if the actual problem is caused by a blend of updates - among the combination of the Extension of interest plus Brave Browser. In other words, eventually (the moment where the combination no longer words) a conflict arises, sometimes, such as with your issue.

I also wonder if the actual problem is some issue with the ‘Preferences’ file inside a Profile folder.

The initial Profile folder - when first installing Brave Browser - is in the folder named ‘Default’:

  • C:\Users\username\AppData\Local\BraveSoftware\Brave-Browser\User Data\Default\

Even though, that is your first Profile - aka ‘Profile 1’ . . . the FIRST extra Profile that you create (Profile 2) is a folder named ‘Profile 1’:

  • C:\Users\username\AppData\Local\BraveSoftware\Brave-Browser\User Data\Profile 1\

CONFUSING? Yes.

  • Profile 1 is folder ‘Default’
  • Profile 2 (now, your test Profile) is folder ‘Profile 1’

Ingenious, si?

Within each Profile folder, there is a file named ‘Preferences’. Various extensions settings are stored within that file named ‘Preferences’.

Depending upon which Profile you are using, in a New Window, go to: brave://prefs-internals/

That allows you to see the many stored settings. Viewing the stored settings, can be heavy geek work.

So, further ‘tearing into the thing, to see if you can make it work’ . . . probably ends, unless you want to use a different extension.

Still, @fanboynz might have an idea to try. He is a whiz re AdBlock, and maybe there is something inside the built-in AdBlock-ing of Brave Browser, that may be tweaked . . . and then LastPASS and Brave Browser will get along again.

Or, perhaps there is some other setting within Brave Browser, that @fanboynz knows about, getting the same improvement.

1 Like

Cool. Yes, I saw that profile creation lol and I see what you are saying.

I figured it must be that one of the two, Brave or Lastpass did some sort of tweak or update that broke it but yeah, I was feeling like I was at the end of my ability to mine the system to find it. I did tweet to Lastpass and they have a dedicated twitter page for support so I am interested to see what they say.

But hey, if anyone else has another last thought I am willing to try it! Thanks to everyone here for all the help! I appreciate y’all : )

1 Like

@Mollie

If you are still willing to test . . .

Please be sure to Disable and Remove your extensions:

  • AdBlock
  • LastPASS

There is a Component folder named ‘cffkpbalmllkdoenhmdmpbkajipdjfam’ within the ‘Brave-Browser’ sub-folder named ‘User Data’.

That Component ‘Updates the ad-block lists supported by Brave regularly’.

Please Exit / Quit Brave Browser.

Locate that Component folder (cffkpbalmllkdoenhmdmpbkajipdjfam):

  • C:\Users\username\AppData\Local\BraveSoftware\Brave-Browser\User Data\cffkpbalmllkdoenhmdmpbkajipdjfam\

and drag that folder to your Windows Desktop.

Now, when you start up Brave Browser, the browser will create a new ‘cffkpbalmllkdoenhmdmpbkajipdjfam’ folder.

Visit Twitter and test your issue.

AFTER that visit, Exit / Quit Brave Browser . . . wait . . . start up Brave Browser AND THEN install your LastPASS extension.

Visit Twitter and test your issue.

Testing with no extensions, or in private window mode. Is generally a good start, then work back from there

@Mollie,
Can you confirm that lastpass is causing the issue for you? I ask because I also use lastpass and have no issues logging in/viewing Twitter content in Brave.