Twitter link wont show up, till I quote post on forums

I have Windows 11. When I post a twitter link on some forums, its ghosted. But if I quote the post in the forum, the twitter link shows up.
When I use Edge browser on same forums, the twitter link shows up, is visible, just fine.
I have the latest browser from Brave… Ad Blocks were tried on and off, no other extensions within the browser…

Could you try in a private window ?
If that doesnt work try in a new profile ?

@Larrys90th Could you provide some more details?

  • Can you link to a forum where this is happening?

  • When you say the link is “ghosted,” can you provide a screenshot and/or provide clearer description? I mean, are you saying the text completely disappears, that it’s not a clickable link, or are you saying that perhaps it’s just showing text but isn’t loading the Tweet quote directly into the forum?

  • What version of Brave are you using?

  • You say “Ad Blocks” were tried on and off, are you referring to Shields or to an adblock extension you’re using?

  • You also say “no other extensions within the browser.” Does this mean you are using extensions? If so, can you try in Private Window and/or in Guest Window? It will help to see if the extension might be what’s causing your problem.

I fixed it. The section in settings where you allow Twitter, Facebook etc to put links was off…

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.