Translate not working at all

None of the Translate extensions work - I’ve tried them all

** 1. Load Extension
2. Go to any page in another foreign language
3. Nothing happens
4. Repeat and try another extension
5. Nothing happens
6. Go to Community support
7. Find a multitude of similar complaints
8. No solutions offered that work
9. Go to Google Chrome and their browser works
10. Wonder why Brave has never fixed this issue
11. Should I continue to try to use Brave or not ? **

Actual Result = All results FAIL = no working solutions on your knowledge pages:

Simple Translation:

Reproduces how often = Always - never works:

**Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10
Brave is up to date

Version 1.27.108 Chromium: 92.0.4515.107 (Official Build) (64-bit)


Additional Information:
I see that this problem has existed for years and it appears that after page after page of people wanting a solution - no working solutions exists. You would think that Brave would prioritize this issue after many years of complaints.

Hey @Curly1WNY ! Welcome to the community :slight_smile:

Can you give an example of one of the extensions you tried to use? We need this to try replicate the problem.

Thank you,



Thanks for trying to help.

Best regards,

1 Like

What behavior is it that you are expecting to happen? For the Google Translate extension, if you want to translate an entire page, you need to visit that page, click the extension icon, then Translate this page:

If you highlight text on the page (up to a paragraph I believe) you can click the tool-tip pop up to translate that paragraph:


Lastly, you may want to check the extension options and see what behavior you have selected for the extension to follow:

1 Like


When I hit the Translate this Page - nothing happens and nothing is translated.

If I cut and paste and place the Italian into the extension - it will translate - but it will not translate the page.


For a moment there I thought I was seeing the same behavior, but after some testing it appears to just be Linkedin that is not translating. They appear to be blocking the extension request intentionally. Can you please try testing the extension behavior on a different website other than Linkedin and see if you’re able to translate the page?

That is a riot !
I just went to another site in German and it translated fine.

I use LinkedIn all the time and this is where I see the most foreign language stuff that I need to translate.


1 Like

My pleasure :slight_smile: