Brave doesn't offer translating webpages

Hello,

When I open webpage in a language different from the default, Brave doesn’t offer translation. When I try to check the square for offering translation in Settings, nothing happens, it can’t be checked.

This happens both in Brave 1.32.106 and 1.33.83. What should I do?

Best regards,
Nikola

@nikolamilevski,
You will have to use the Google translate extension that is offered to be installed in the browser. Check your brave://extensions page to see if the extension is enabled.

Thanks for your support. That doesn’t work for me.

I had Google translate extension. I uninstalled it, installed it again, allowed everything that was there to be allowed, restarted Brave. Still, there is no offer for translation. Even more, when I click on the extension and then “translate this page”, nothing happens :frowning: This for every language I tried.

@nikolamilevski,
Can you please tell me what OS you’re using?

I am using Windows 10.

@nikolamilevski,
That should definitely be working. Can you please try highlighting some text, then right-clicking on the highlighted text, then select Google translate from the context menu and tell me if this takes you to the translation page?

Yes, that works. But translating a whole page still doesn’t.

@nikolamilevski,
Just to confirm, this is the option that isn’t working for you?
image

Yes, that is the option. Nothing happens when I click on it. Ideally even better should happen. Brave should automatically translate webpage if it is written in a language I don’t understand.