Transaction Not Showing Up In My Wallet


Description of the issue: Funds not showing up in my Brave Wallet after 24 hours

Are you using the (new) Brave Wallet or the (old) Crypto wallets implementation? New Brave Wallet

How can this issue be reproduced?

Brave Version (check About Brave): 1.43.89

Additional Information: I sent USDT from FTX 25 hours ago but i don’t see it in my Brave Wallet.

Did you use the correct network?
Are you able to see your transaction in Etherscan?

One last hint: most exchanges froze ethereum transactions due to the merge expected to happen in few hours. Could it be the case? DId you check FTX announcements?

Yes, I can see the transaction in Etherscan. Shows Tokens To and From 2 1/2 days ago. I made sure I copied my Brave Wallet account number when i made the transaction

@mccrtny is it enabled in your assets? Because it’s not on by default, so it wouldn’t show in your Wallet until then, even if it has arrived.

Go to brave://wallet/crypto/portfolio/add-asset and look for it on the list, then hit the checkbox. Other way to get there on Desktop is brave://wallet/crypto/portfolio > Visible assets

If on Android it’s Wallet → scroll to bottom → Edit Visible Assets

That was the problem. Thanks for your help

1 Like