Top sites not displayed

Version 1.13.82 Chromium: 85.0.4183.83 (Official Build) (64-bit)

after update, top sites are no longer displayed. home screen is completely blank.

how to enable top sites?

go to setting then New Tab Page then enable top sites
also do you enable clear on exit option if you do then at least uncheck the browsing history option

For me it was already enabled. After last update it stopped working. Making a new profile didn’t help either, nor disabling/enabling Top Sites.

That was enabled before and after the update: no top sites displayed. New profile has no effect. This is not the first bug encountered with Brave, which is otherwise a very good browser.

uh, how to delete the new profile? I cannot find any means to do so.

to delete profile go to profile manager then you will find 3 white dot in the upper right corner click on it then remove
it the worest color they choose relating to the background

i even report that in this post and even give suggestion Profile manager accessibility issue but no one answer

hope that help and have a nice day

When I go to profile manager and open that, there are no 3 white dots in the upper right corner. There’s only the possibility to add another profile. Not to remove them for me.

After great frustration, I discovered what ‘justsomeone1’ tries to explain. If you have more than 1 profile enabled, you should have a circular icon at top right of screen, in the area where icons for extension are displayed. Click that circle to invoke the ‘profile manager’. You should then see circular icons for each user, each within a square. Move cursor to top right of icon square, to see the 3 vertical white dots (very faint). Click the dots to display the next dialogue pop-up, then click the remove option.

But. my bug, (ie no top sites displayed), is not resolved by adding/deleting profiles. If I delete my own profile, (ie the default), I lose all passwords, setup, etc, and must start anew. Brave is woefully inadequate to export/import my own passwords to/from a csv file, which means many long hours of frustration to restore my own data to my own, new profile. This is my biggest peeve about Brave. I realise bugs are always a possibility, but the inability to purge Brave and restore user data quickly is a major flaw.

click on that circle then click the setting icon next to the other profile that will open the profile manager

your default/old profile will be named profile one do not delete that your new profile will be named profile 2 3 4 depend on how many profile you have


if you delete your old profile you loose all those things

not sure why you still has top site issue

I know, I did that, I can make it to my profile manager, but there are no 3 white dots anywhere to delete the 2nd profile I made to test if the Top Sites would come back. They also do not appear on the little square of the profile picture either.


rbg is not the only one who has the problem of Top Sites not showing. I have it as well after the last update. And there’s another topic about it as well where someone mentioned it. Now, for him it worked after making a new profile. But for 2 other people (me included) it did not work. It is marked as a solution, but it really is not if it only works for some people and not for other people.

it exist but it’s color match the background that’s why it hard to find check the screen shoot

check the location of the mouse

according to this

the new profile helped but since it did not helped you then sorry i really do not know what the issue

hope that help and have a nice day :slight_smile:


Ah yes I managed to remove the extra profile. Thnx!
And for some weird reason, after a kernel update today on my Linux Mint 19.3 system, the topsites seem to work again. ^^

you welcome and congratulations :slight_smile: