Tokens not showing in wallet

I executed a swap on Raydium, but the swap is not reflected in my wallet. My balance is lowered, but the new tokens are not shown.

I checked my wallet on Solscan, and see the correct balance, but not in my Brave Wallet.

I’m using the latest browser version, and tried clearing my cache. My Brave Wallet is still not showing the swap, except for my balance cut in half.

@CarbyWargrains first thing, want to point out the Sandeep-help5 is a scam account. I’ve flagged the post and the account should be banned here later. That said, if you receive the email update and see link they provided, don’t click it. They just will try to get you to provide info so they can steal all of your crypto.

Do you actually see the coin or it’s not listed? Big question is whether the coin is a visible asset in your Wallet?

Second thing, when you say you check Solscan and see correct balance, are you saying it shows the swap done and correct balances on both ends of things?

Third, which kind of ties into what I was saying just above, I want to make sure you can verify to make sure the accounts are accurate and there was no typo or anything.

I assumed it was a scammer, and didn’t click anything. Thank you.

I only see one coin in my wallet, when there should be two. Unless it’s the type of coin that would not be reflected for some reason?

Here’s what I see in my wallet, and below that, what I see in Solscan:

Screen Shot 2024-03-30 at 4.30.44 PM
Solscan:
Screen Shot 2024-03-30 at 4.34.52 PM

My wallet is also not showing any transaction history, when I would have thought it would show the swap:
Screen Shot 2024-03-30 at 4.32.50 PM

I have very limited knowledge on Wallet, so take things I am about to answer with a grain of salt. I’m not saying it’s 100% accurate, but am going with some assumptions and sharing basic understanding through observations only.

Swap is generally done through third party, so you would have that in whatever they showed. You still would think something would show in transaction history though.

Issue is whatever you did must not be in self discovery. So you’ll have to add the asset. You can kind of see instructions on checking this at my little FAQ at Adding new asset to Brave Wallet or Brave’s official guide at https://support.brave.com/hc/en-us/articles/20643855700109-Adding-a-Custom-Token

jeo boden is not a token automatically in Brave Wallet from what I can tell, as I had just looked for it in all Available Assets and it’s not there. So we’d have to Add custom asset and provide details for the coin. Then it should be able to pull up in your portfolio

Ok I added the asset through the Custom Asset path, and I see it listed now, but my tokens and my overall balance are not showing those assets as being included.
Screen Shot 2024-03-30 at 7.25.16 PM

I’m guessing something got input wrong. Earlier you showed a screenshot showing you have/had 1,430,259 or whatever of boden. Now in this most recent screenshot from where you added, it’s showing like you have 14,302,598.54. So somehow that number got inflated. Not sure if it’s because of the decimal of precision chosen or how that works.

Value may be working in a similar fashion then, just kind of glitched out. Unfortunately, we’re past the extent of my knowledge. Typically we don’t have anyone from Support active on the weekend and Wallet issues also tend to lack in support overall. We used to have Hub who would come by often, but he left Brave and now it’s just @jleonard , @StephenHeaps and all, but they dont’ seem to come around often. Then in terms of Support, it’s just @Evan123 who handles Wallet and Rewards stuff.

There’s also people like @onyb but haven’t seen them respond since they were tagged nearly a month ago in topics such as Wallet 'Unable to fetch fee estimates' on Telos network - #7 by jleonard so not sure chances of them being able to help.

In any case, tagged where I can in hopes to get someone from Brave to help. Just may have to give it a little time. And I guess can report back if you end up seeing it resolve by deleting and adding again or something.

Ok thank you for your help.

Hey @CarbyWargrains, @Saoiray is likely correct that this is a decimals input issue for the custom token. You posted a screenshot of your own wallet address on Solscan so I’ll try and guide you from there. On your own wallet address page on Solscan in the Overview section, click the drop down where you saw your jeo boden token balance and click on the jeo boden row to be taken to the token details page. From there you should see the decimals value in the Profile Summary section near the top.

Assuming I have the correct token detail page for Jeo Boden token the decimals value should be input as 9. This can be edited on Brave desktop via the ... menu.

1 Like

Thanks for that, @StephenHeaps. Later on, if you could, I am curious…would the decimal placement still have screwed with the fiat value? Like even when it was messed up and showed 14 million boden coins, it was saying value of $0.00. But value at the 1.4 million tokens according to their other screenshot was $484. Regardless, shouldn’t it be showing greater than $0.00?

That’s essentially primary thing I was tagging on. Though I guess also should have confirmed with @CarbyWargrains what token address they used, making sure it was trying to pull from 3psH1Mj1f7yUfaD5gh6Zj7epE8hhrMkMETgv5TshQA4o

Anyway, really appreciate the response.

Your coin could still show up later. I guess you need some patience so you don’t stress unnecessarily. After another one day you check it. Hopefully you will see it appear

@Saoiray Fiat value should be users balance of the token multiplied by the fiat value of the token in users currency (ex. token value in USD). Incorrect decimals would effect the users balance, so it may be a price fetch issue given they have some balance showing but $0.00 fiat value (often assigning Coingecko ID helps these with added custom tokens).