Timestamp for gmail is incorrect

#1

Have not found a solution to this in search. A few weeks ago the timestamp for emails received in gmail started incorrectly stating the time as 6 hours ahead.
I have checked my computer time and everything is correct. The problem seems to be with the Brave Browser. There was an update available, which I installed, and the time reported correctly. This morning the time was back to 6 hours ahead. The new update is: Version 0.59.5 Chromium: 71.0.3578.80 (Official Build) dev (64-bit)
I opened gmail in Internet Explorer earlier today and the timestamp was correct.
I have googled this problem and tried other options like opening a google doc spreadsheet and checking the time there, opening time and date on the lower right and synchronizing internet time. This actually worked for a short while before reverting.
I am hoping someone has a fix for me.

0 Likes

The clock on the new tab page displays the wrong time after a while
#2

@hadenuf,
Timestamp seems to be fine for me. What OS are you using?

0 Likes

#3

Windows 7. I just closed Brave and reopened again and the timestamp was correct in gmail. I guess this means I can’t leave Brave open continuously?

0 Likes

#4

I’ve never had this issue before. Do you have any extensions installed on Brave?

0 Likes

#5

I have Private Internet Access and Wikibuy.
On the VPN I am connected to a server in the same time zone.

0 Likes

#6

Ahhhhh - it may be the same timezone but I can almost guarantee you that’s the issue. My very next question was going to be if you were connected to a VPN :slight_smile:

Try disabling it and see if the time remains accurate. Lemme know if it resolves the issue.

0 Likes

#7

Thanks! I will try that when the timestamp is incorrect again and see if that will solve it. I will let you know.

1 Like

#8

I’m having the same issue only my email accounts are Proton Mail and Earthlink. Sometimes the timestamp on Brave’s homepage will be correct and sometimes it is 6 hours ahead. But I will see emails timestamped 6 hours ahead even if it’s correct on the homepage. I’m not using a VPN.

0 Likes

#9

@ann, thank you for reaching out.
Good to have this information - may be a Brave issue after all. Going to reach out to the team again and see if anyone knows whats going on.

What Operating System are you using?

0 Likes

#10

I’m using Windows 7 too.

0 Likes

#11

@ann
@hadenuf
Can you confirm the following things for me:

  1. With Shields down, is timestamp still offset?
  2. Do you have location services disabled? You can click the lock icon on the lefthand side of the address bar to check this. If enabled, it should appear in the box, along with any other permissions the site would ask of you.
0 Likes

#12
  1. Yes, with Shields down, time is still 6 hours off. I checked the homepage and it was showing the correct time.

  2. Location on both websites is showing Ask (default) in Settings. Is that what you needed?

I also checked Ebay which was having the same issue. I was following an auction which shows it ends at one time but on another page it shows a different time. The time which is off is the page which shows the countdown. I hope this makes sense.

1 Like

#13

My timestamp is still correct after restarting Brave earlier. In the past I have tried with shields down and it did not correct the problem, but if it happens overnight again I will try the recommendations and let you know the results. I did see that location says blocked by extension.

0 Likes

#14

Just an update. When I restarted my computer this a.m. both emails were showing correct time. At approximately 7 a.m. CST the timestamp on Proton Mail flipped to 6 hours ahead but Earthlink emails are still correct.

Edit: I use my laptop for emails. When I opened them on my desktop, the timestamps are correct.

0 Likes

#15

When I put my desktop to sleep last night the gmail timestamps were correct. When I woke it this morning the gmail timestamps were 6 hours ahead.
With shields down they stayed ahead. Clicking on the lock icon did not show anything named location services, but it did show one just named location. It said “blocked by an extension”.
So after that I closed Brave and opened again and the timestamps were correct. I did not have to reopen any tabs that were open before I closed Brave.

0 Likes

#16

I just put my desktop to sleep and woke it up and the timestamps were ahead 6 hours. So it happens each time the computer goes to sleep and wakes up. Gremlins?? :astonished:
It may not be a complete fix but at least I know how to deal with it.

0 Likes

#17

Apologies for the late response everyone.
This is all very strange, tbh. Before I go file an issue for it though I’d like to try a couple other things. The main one surrounding what @hadenuf mentioned in a previous reply:

:point_up: I’d asked if extensions were installed, as they sometimes interfere with certain Brave functions (working on hammering these issues out internally already). This is hard to test and can give inconsistent results sometimes.

For anyone here experiencing this issue, try disabling all extensions before restarting the browser.

To do this, open the main menu, go to More Tools --> Extensions and toggle any extensions listed here to “off”. Now, close the browser (and/or end the process), reopen it, and (before enabling any extensions) check the relevant timestamps again.

Let me know what you find.

0 Likes

#18

I disabled the extensions on my laptop and restarted it. So far everything looks normal but it can sometimes take hours for the time to flip, so I’ll keep an eye on it. This would explain why I didn’t have a problem on my desktop. I checked all the settings and they were the same on both computers but I don’t have any extensions added to the browser on the desktop.

1 Like

#19

Appreciate your diligence @ann.
If this ends up being the issue (extensions enabled) we’ll pin-point which extensions cause this behavior and get this issue logged so devs can work on a fix.

Additionally, if the time does stay accurate as you continue to browse, try re-enabling the extensions again and monitor behavior to see if the timestamp is flipped again.

0 Likes

#20

Bad news. I have extensions disabled and I just noticed my emails on both providers flipped. It happened at about the same time yesterday. Is there something happening at approximately 7 am CST?

The times on the desktop are still correct so I restarted computer but they are still showing the right time. So it’s just happening on my laptop. I verified I have the same version of Brave on both computers.

???

0 Likes