This site can't be reached

No worries about the delay! I’m not sure if I am turning these off right, but here’s a list of everything that I did:

Norton on, MWB on: ERR_TIMED_OUT

Norton off (Disabled Smart Firewall and Auto-Protect), MWB on: Worked for a few minutes then ERR_TIMED_OUT

Norton on, MWB off (Quit out of MWB): ERR_TIMED_OUT

Norton off, MWB off: ERR_TIMED_OUT

Remove network Proxy: Settings already set to automatically detect settings and use a proxy server for your LAN is already unchecked.


Reset Cryptographic services: ERR_TIMED_OUT

:thinking: :thinking: :thinking:
Very strange – I’m fairly certain (still) that this is A/V related, but its hard to tell what exactly it is, especially after you disabling both. I would suggest trying to disable both of these and then restarting your PC before testing.

I’m reaching out for further assistance from the team as I seem to be out of ideas here – appreciate your patience on this. Let me know if disabling both and rebooting changes anything. If not I’ll be back when I (hopefully) have more information.

1 Like

If you’re still down for more testing (and lets be honest – who isn’t down for more testing?), I’d like to try something a little more complex. Please try the following:

  1. Launch Brave and attempt to visit (this should land you on the connection time out error screen, assuming nothings changed)
  2. Go to Menu --> Tools --> More Tools --> Developer tools to reveal the Dev tools window.
  3. Click the “more” drop-down menu on the top right, select Network Conditions:
  4. You’ll see the Network Conditions tab appear at the bottom of the window – in the User Agent section, deselect the Select automatically check-box, and choose Edge -- Windows as your new (temporary) UA string as shown above.
  5. Now, switch to the main brave window where you attempted to visit and hit refresh.

After doing this, can you,

  • Tell me if the page displays as intended, if you get the same error message, or if the behavior change at all.
  • Switch back to the Dev tools window, and open the Console tab – take a screenshot of any output displayed here and share it in this post.
1 Like

I just want to say that i’m having the same issue, I have MWB and NordVPN. Though even with killing both tasks issue still persists. For me its just, but it still loads fine in edge. Tried disabling extensions as well, no luck. loads fine for me, so theres that.

Edit: Actually connecting to my VPN fixes it. That is, allows amazon to load. Must be a connection there.

I’m always down for more testing! So, this is what I got:

  1. Launched it, yep still ERR_TIMED_OUT.
  2. Found it!
  3. Clicked it.
  4. Whatarethesethings found it! Closed dev box.
  5. Refreshed it, still ERR_TIMED_OUT ;-;

And here is what the Console box says:

Hopefully I took a screenie of the right thing. I did not try to restart my comp yet with everything disabled, I just got home from work. I can still do that if you would like me to. I has work tomorrow as well so it’ll be another late replay from me as well so don’t worry about being late!

@Mattches could the Norton and/or Windows firewalls be blocking Chrome/Opera/Brave?


That’s the spirit!

I do notice in step four that you say

When performing this test, you should have the Dev tools open the whole time – the UA string will only persist until Dev tools are closed. Please try again if you did end up closing the window before refreshing with the new UA selected.

Let me know – I’ll have to scratch my beard on this. My money is still on one, both or all of these AV services.

1 Like

I’m sorry for the late reply again, work has been very draining recently. So I am very tired but I think I did it right this time? Because I have this up:

I’ll be home tomorrow so I should be able to reply quickly. I’ve checked out other webpages and they seem to load right.

Edit: After going around some more looking at webpages, I eventually got the ERR_TIMED_OUT again.

Hi, i’m new here and i’ve been looking for fixes for this exact same issue. I have run throught the same process as michou and still get the ERR_TIMED_OUT thingy.

It usually loads properly when i start it but then as i load a bit more than 1 page, the sites stop responding.

Sometimes, i have access to some page that loads and others won’t. and as long as i don’t close the page i have access to, it works fine up until it doesn’t. (but it takes a good 5 mins to stop working)

@Mattches Sorry for the @ but I have some great news! I’m not sure what update did it, but I can finally use Brave again! Web pages load fine, I installed extensions, and browsed around for hours with no problems! This is the second day of me using Brave successfully and I couldn’t be happier! Now I just gotta update my bookmarks and re-sync everything! :clap::grin:

1 Like

I’m not entirely sure what the issue was but I’m very glad you’re able to use the browser now :slight_smile:
Please don’t hesitate to reach out if you have any further issues – hopefully we can solve any others you have in a more reasonable time!

I was just about weigh in too. I couldn’t load files but latest build of Brave has fixed it. Well done.

1 Like

Open Location and try :grinning: