Sites are timing out

I was using Windows 7 as my main OS and had very little issues using brave on Windows 7. I recently installed Windows 10 (dual boot 7 and 10) and I am unable to use Brave because my loading sites keep timing out and I receive the message “This site can’t be reached, took to long to respond” message. Version 0.68.131 Chromium: 76.0.3809.100 (Official Build) (64-bit).
When I boot into Windows 7 I do not have this issue. I have tried resetting settings, uninstalls with cleaning up leftovers but what I have tried does not help, there must be something that I am missing with Windows 10. Occasionally a page will load such as my outlook mail account but most pages will not load.
I am using Windows 10 Ultimate 64bit on a wired connection. I am not having any issue using firefox or chrome, only Brave.
If this topic has been discussed and solved already I would appreciate a link, Thanks.

Hey, sorry to hear! Which sites are timing out?

Just about every site, amazon, kijiji, let go, facebook, youtube, too many to list. Occasionally one like outlook mail will load but not always and when I tried yesterday facebook would take long to load and when it finallly did load, the page was not displaying properly (all large fonts on a white page with no graphics).
Like I explained in my original post, if I boot Windows 7 (same computer) Brave works fine, I am confused to what the difference between the 2 operating systems is

I don’t know what changed but things started working again today, sites are loading fine. I now can go back to using Brave.
The only thing different is we changed our internet provider from Telus to Shaw.

It may have been an extension causing this particular issue – also, switching ISPs may explain it although it’s less clear why that would be the case.

I had no extra extension enabled and the only other thing that I can think of is that we upgraded our speed, however, Brave had worked fine with our old internet connection on Windows 7 so I am at a loss as to what changed. Oh well, at least it is working now, I thought that I was going to have to continue using firefox.

1 Like