The website of a newspaper displays a crypto's website instead

Description of the issue:
A secure and public website of a newspaper has stopped working 2 weeks ago. Now displays this website instead https://amp.dev/documentation/guides-and-tutorials/start/create/basic_markup/

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Go to The url
    Website of a newspaper
    https://expreso.com.pe

  2. Instead of displaying the website, displays a different website, something related with cryptos

  3. Try the same url on Google, Mozilla or Edge

  4. The website will be properly displayed

Actual Result (gifs and screenshots are welcome!):
Website is not displayed.

Expected result:
The website should be displayed because it’s a public website and uses https.

Reproduces how often:
Always

Operating System and Brave Version(See the About Brave page in the main menu):

Additional Information:

  1. This started to happen 2 weeks ago.
  2. Happens with PCs, laptops, but doesn’t happen with Android.
  3. Til yesterday, the issue happened also with this website https://www.claro.com.pe/personas/
    , today it’s not happening. Even, some users of the forum got to see this.
1 Like

Confirming: clicking on expreso <dot> com <dot> pe does redirect to the amp <dot> dev website. The amp <dot> dev site appears to be legitimate / has nothing to do with crypto but neither does it have anything to do with the newspaper. Adding: I did a separate search for the newspaper which offered the same link you provided. Clicking on the link in the search result also sent me to the amp <dot> dev website.

None of this helps resolve the issue, but it’s not specific to your installation.

2 Likes

@marcosoyola ,

May be stranger than fiction, but the following might be related(?!):

Meanwhile, using Brave Browser v1.37.116 > New Private Window, I just visited

https://www.expreso.com.pe/

without any issues. The following is a screenshot of the site-specific Shields (Lion icon) panel:

I did not Allow any of the scripts mentioned, but the main web page displays and links thereof, work.

There was a prompt (caused by the website or Brave Browser - I am uncertain), to install a Google translation tool, but I canceled/declined that pop-up window’s effort.

1 Like

The comment from 289wk suggested a course of action but was opaque as to how to proceed.

  • go to brave://flags
  • search for Enable De-AMP and select Disable
    (It seems ‘Enable’ is the default but that’s not revealed until trying the alternatives.)
  • restart Brave

Clicking on the expreso link in your original comment now correctly loads the newspaper site (at least for me).

Relevant to your experience with other browsers, specifically checking Chrome’s available flags, I found nothing related to ‘De-AMP’. It seems this flag is unique to Brave. What’s peculiar — and why I pursued this: the problem also appears to be unique to this newspaper’s website. That’s quite a set of coincidences.

Adding: I’ve been using Brave since late-2016. During that time, I occasionally edited flags. Sometimes, those edits didn’t work well with subsequent Brave versions. If you edit the Enable De-AMP flag, make a note of what you do so you can un-do it when that seems appropriate.

2 Likes

Hi @289wk, yes it was related with the link you posted. I disabled the Enable De-AMP feature and got to see the newspaper’s website again.

Also, I tried the method of the New Private Window, but for me, unfortunately the result was the same. Maybe because I have the Brave’s version 1.38.111

The issue is now solved. :+1:

Thanks

1 Like

Yes @redbike9, I disabled De-AMP, the way you told me and got to see the newspaper website again.

Thanks for your support! :smiley: :+1:

1 Like

@wavesound , @Mattches ,

Yet another issue probably [somehow] caused by the “de-AMP” thing.

Glad to help out. You might want to mark the topic as ‘solved’. That said, with Brave’s new de-AMP flag defaulting to Enable, I suspect this problem is going to occur for other web pages.

1 Like

It probably is caused by something with the source code from the website. It has the following line with the url that is loaded with de-amp enabled

<!-- <link rel="canonical" href="https://amp[dot]dev/documentation/guides-and-tutorials/start/create/basic_markup/">

-Edit

I found this info about the canonical tag, which is why I thought de-amp shows that page, I could be wrong though, I am not familiar with AMP

The canonical tag is a mandatory element for AMP pages to be considered valid, and the canonical tag is supposed to point back at the original ‘non-AMP’ version of the page. If the page is standalone AMP, then the canonical should be self-referential.

To get an idea about, what is AMP (Accelerated Mobile Pages)

amp-bind - example:

1 Like

As I have very little website coding knowledge,
Could someone who has actual knowledge of html/amp check if what I posted above could be the issue?

I think the expresso site uses some wordpress AMP feature or extension which may not have been setup correctly? The page which is shown is the exact same url that is set as the canonical href.

I used bromite for android in desktop mode with a custom user agent to view the source.

Hi

@marcosoyola

Another alternative solution is to disable AMP @ brave://settings/?search=amp

2 Likes