The recaptcha is not working

I’m trying to connect my Gemini wallet on the Brave browser. I go to a new tab. It says “Log in to Gemini to see your balance” I click. I try to log on to Gemini, fill in my info and then I click “I am not a robot”. The idiotic recaptcha pops up. I click on a picture that is the bus, bicycle, traffic light, etc. that it is asking me to click on and I get the message:

“Cannot contact reCAPTCHA. Check your connection and try again.”

I hit the “OK” button, the captcha disappears, and nothing happens. I contacted Gemini, and they say to contact Brave.

Description of the issue:
How can this issue be reproduced?

Expected result:

Brave Version( check About Brave):

Additional Information:

I need to add that I was able to log on to Gemini from my Firefox browser. But I want to connect my Gemini wallet/account to the Brave browser, and I can only do that if you figure out how to make it work on the Brave browser. And I don’t use Firefox anymore, unless I’m having problems with Brave - And there are other sites that give me the recaptcha puzzle, not just Gemini, and it won’t work on other sites either. Same message all the time - unless I get the recaptcha on Firefox, then it works.

@zee644

reCAPTCHA is a Google thing. If www.google.com is blocked somehow, somewhere, then reCAPTCHA will fail, somehow.

For a website - let us call it www.trouble.com - that has a reCAPTCHA problem . . .

Cookies check

In a Brave Browser > New Window, go to: brave://settings/cookies and in the upper-right area of the window, enter into the Search field: trouble.com

Then, search down the cookies settings page and check to see if the troublesome domain trouble.com shows under Sites that can never use cookies. If the troublesome domain shows there, then remove the domain entry.

Repeat that search and test, for domain google.com - see if www.google.com is blocked.

While at the cookies settings page:

  • Enable: Block third-party cookies
  • Disable: Clear cookies and site data when you close all windows
  • Remove all: Sites that clear cookies when you close them
  • Do not use: Sites that clear cookies when you close them (better to clear those cookie sites/sources, manually: brave://settings/clearBrowserData)

JavaScripts check

In a Brave Browser > New Window, go to: brave://settings/content/javascript and in the upper-right area of the window, enter into the Search field: trouble.com

Then, search down the javascripts settings page and check to see if the troublesome domain trouble.com shows under Not allowed to use javascript. If the troublesome domain shows there, then remove the domain entry.

Repeat that search and test, for domain google.com - see if www.google.com is blocked.

Go to: brave://settings/clearBrowserData

For tab Basic:

  • Set: Time range:All time
  • Enable: Browsing history
  • Disable/Enable: Cookies and other site data (When Enabled, Signs you out of most sites)
  • Enable: Cached images and files

Click on the ‘Clear data’ button.

(The ‘Clear data’ button also saves the selections.)

In a Brave Browser > New Window, go to: brave://settings/cookies

Scroll down that cookies settings page to Sites that can always use cookies

Click the Add button

Enter www.google.com:443 as the site . . . but Do Not Enable:

  • Current Private session only
  • Including third-party cookies on this site

Click the Add button

Repeat those steps for:

  • www.gstatic.com:443

In a Brave Browser > New Window, go to: brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter www.google.com:443 as the site . . . but Do Not Enable:

  • Current Private session only

Click the Add button

Repeat those steps for:

  • www.gstatic.com:443

If " reCAPTCHA is a Google thing. If www.google.com is blocked somehow, somewhere, then reCAPTCHA will fail, somehow,"
why does Brave use their captcha to keep me from connecting my Brave browser page to my Gemini account - which is where my BAT is directed. One of the main benefits of the Brave browser is I get to stop using Google. Now you are telling me that I have to allow Google cookies?

Going to Brave “settings” - there is no link to “content” or “javascript” under “settings”

@zee644

Google reCAPTCHA is not Brave Rewards’ captcha.

Using:

  • Brave Rewards and/or the Brave Wallet (Custodial)

  • Custodial Wallet Provider and exchanges such as Gemini, Uphold (and consequently, Google’s reCAPTCHA)

is your decision.

I am not satisfied with certain requirements of the Custodial Wallet Providers . . . and what probably Brave Browser users may end up with, using the Brave Wallet as a more-capable Crypto- Custodial- Exchange -type Wallet . . . that is proposed and in development (it seems).

Said ‘certain requirements’ being that, in order to obtain an account and use such Wallets, the customer hands over personal information including government ID to people whom the customer has never met.

I use Brave Browser for Privacy and Security - the prime objective (that was?) for Brave. I do not use Brave Browser for vBAT nor BAT ‘benefits’ that may result in my accumulating Crypto-something and tangible, in-hand cash.

The only usefulness that I find in vBAT (not BAT), is for tipping Creators and Publishers. Via tipping Creators and Publishers, there is a conversion of vBAT (departing from Brave Rewards wallet (lower-case ‘w’) to BAT in said Creators and Publishers accounts.

But, I do not participate in Brave Rewards. Though, I try to help Brave Rewards users find info, that will in turn, help them with the studies of their problems.

I wrote what may help you, but you may skip the cookies part and . . .

In a Brave Browser > New Window, go to: brave://settings/content/javascript

It’s not just Brave/Gemini - It’s your browser. Now that I deleted cookies in an effort to follow your recommendations - a lot of the websites I try to log back onto are giving me the reCAPTCHA to prove I’m not a robot, and I’m getting the same problem. I’m going to have to stop using Brave if everywhere I try to log on becomes impossible.
I’ve been using Brave since November, and I love it. This is a recent development - something has changed. You should consider fixing it.
I repeat - it works just fine on Firefox.

Sorry if I misunderstood that you are not a Brave support person.
Reading again, I tried looking under settings and do not find content or javascript listed as options to go to.

@zee644

You are OK.

I look at ‘reCAPTCHA is not working’, and suggest a bunch of things to do, in order to get reCAPTCHA working. et Viola!

Probably by now, you want to adjust some of the ‘Clear Browsing Data’ settings, so that you are again saving certain cookies.

Now, read carefully:

In a Brave Browser > New Window, go to: brave://settings/clearBrowserData

That means, that you would ENTER in the URL address field of a Brave Browser > New Window, the following character string:

brave://settings/clearBrowserData

That character string is what is called a Brave URL address. Just like, what I wrote earlier:

In a Brave Browser > New Window, go to: brave://settings/content/javascript

The Brave URLs take you directly to certain, usually New Window, web pages of the Brave Browser (usually).

brave://settings/clearBrowserData is akin to:

Brave Browser > Settings > Privacy and security > Clear browsing data:

Screen Shot 2022-07-19 at 10.50.33 PM

brave://settings/cookies is akin to:

Brave Browser > Settings > Privacy and security > Content > Cookies and site data:

Screen Shot 2022-07-19 at 10.53.55 PM

brave://settings/content/javascript is akin to:

Brave Browser > Settings > Privacy and security > Content > JavaScript

I suggest that you create Bookmarks for each of:

  • brave://settings/clearBrowserData
  • brave://settings/cookies
  • brave://settings/content/javascript
  • brave://settings/shields
  • brave://settings/content/all
  • brave://settings/rewards

You get the idea.

PS1. Be sure to carefully read all the switches at:

  • `brave://settings/clearBrowserData

and the settings at:

  • brave://settings/cookies

in order to preserve the sources for cookies, that are important to you.

PS2. You may find, that your website visits work better, when using:

A Brave Browser > New Private Window