Google reCaptcha fails on Brave

Hello, I’ve not so recently been having problems with the Brave browser regarding the Google reCaptcha system, it’s super annoying since I can’t complete registrations, logins, confirmations, nothing that involves completing a reCaptcha.
Whenever I try to complete it gives me the message:
Cannot contact reCAPTCHA. Check your connection and try again.

I don’t know what to do, but at this rate I’ll eventually leave Brave.

Disclaimers:
No proxy
No VPN
reCaptchas works on literally every other browser I have
Works on Private mode
I have the latest version of Brave
Doesn’t work even tho I have no extensions

Description of the issue:

Steps to Reproduce (add as many as necessary): Go to a website that requires you to complete a reCaptcha, try to complete it…

Actual Result (gifs and screenshots are welcome!): Doesn’t work.

Expected result: Should’ve completed without problems.

Reproduces how often: Everytime

Operating System and Brave Version(See the About Brave page in the main menu):
Version 1.33.106 Chromium: 96.0.4664.110 (Official Build) (64-bit) - Windows 11 and Windows 10

Additional Information: Please tell me ways to fix this.

Does it have to do with braves shield?

No, already tried multiple times without shield and it doesn’t work.

image
Same here. Any updates? It happens on all pages on the google reCaptcha.

[
Version 1.34.81 Chromium: 97.0.4692.99 (Official Build) (arm64)
]

Can anyone here experiencing this issue share any specific sites/links that you are unable to complete the reCAPTCHA on so I can test on my end?

https://www.businessregistry.gr/publicity/index

This is an example.

I was able to complete this reCAPTCHA without any issues. Are you using a VPN by chance?

No I am not. From mobile works but from the desktop browser not. Also i see this wrapper error in the console:

@kostaschar92,
Can you try changing the fingerprinting option in the Shields panel while on the site to Allow all fingerprinting and test to see if it works after that?

Nope. It’s the same!

It’s a problem ! It made me maniac ! I just swap from the firefox to Brave and this recaptcha problem :frowning: I am not using VPN i am not using Proxy ! I tried even Beta version it’s the same .

1 Like

Since we have four different people here claiming the same thing, it would be helpful to have the following information from everyone encountering the issue:

  • An example site where you see this behavior
  • Whether or not you have any extensions installed
  • Whether or not you are able to complete the test when using a Private browsing window
  • What browser version you’re using
1 Like

@kostaschar92,
Can you also confirm that disabling all the extensions installed does not resolve the issue?

Actually it was one of the extensions that was causing the issue!

2 Likes

I figured that might be the case. Would you mind sharing which extension so we can help other users if they’re encountering the same issue? Thank you.

It’s the urban-vpn (https://chrome.google.com/webstore/detail/urban-free-vpn-proxy-unbl/eppiocemhmnlbhjplcgkofciiegomcon)

2 Likes

Thank you for the information.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.