Tapping on a link goes to Chrome browser

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Delete any text above the line separator below before posting

When tapping a link on any website, the link uses Chrome instead of Brave. How can I make it use Brave.

Hi @Providence,

Thanks for writing in!

  1. Launch Brave and open the main menu.
  2. Select Settings.
  3. Scroll down until you see the Default Browser section and select Make Default .

Hi Steeven,

Brave is already my default browser. Still, when I click on a link, it uses Chrome.

Try going to Windows System settings --> Default Apps --> Default apps by file type and ensuring that Brave is set to be the default app to open .html files

Both .htm and .html are set to default Brave.

Can you tell me what version of Brave you’re using as well as what version of Windows OS? Additionally, just to confirm, this happens when you click any link from anywhere? For example, if you click this link, it will open a new instance of Chrome?

Version 1.2.43 Chromium: 79.0.3945.130 (Official Build) (64-bit) Windows 10.

When I clicked on the link you provided, it opened Brave’s download page (in Brave). Hmmm!

I think I figured it out; I receive notifications from different chrome interfaces. I believe that when I access the notifications through them and then click on a link, it stays in chrome.

Thanks for your help in figuring this out.


1 Like

My pleasure – glad we got it sorted :slight_smile: