Sync totally failing since update to 0.68.138


Description of the issue:

All my Brave browsers, including Windows and Android have had their sync’d bookmarks either deleted or duplicated since I upgraded yesterday. On one machine Brave just kept closing down every 20-30 seconds but all the others have been fine - removing just that machine from the sync group made no difference except to stop the crashing. The only thing that has resolved the problem is to kill my sync group on all machines entirely and manually re-import my bookmarks from a backup.

I’d add more to this ticket for support, but I can’t really think what else I can provide considering my only fix it is to disable the problem or risk re-doing it all again.

@Taomyn,
I understand your frustration and have recently dealt with the same issue personally. The team has several changes to the Sync system in the works as well as additional sync features.

2 Likes

Well I hope it includes some kind of feedback from the process as waiting to see if “something will happen” like it’s magic is infuriating and also some kind of “Force sync” that syncs the current browser to all the others.

1 Like

@Mattches I see that 0.68.139 has been pushed out, but can you or anyone confirm if this contains a fix for Sync? The release notes don’t mention it so I suspect not, but that would be surprising considering how damaging this bug is.

1 Like

It’s still not working for me, even after I blew up the sync chain and started over.

@Taomyn – the update to 0.68.139 will fix some users Sync issues but not all. There are many different cases/scenarios WRT this issue and will take a while to parse each of them out.

That said it is high priority right now and we hope to have all these Sync issues resolved as soon as possible. Apologies for the inconvenience and thank you for your patience.

2 Likes

Any update about the fix of the Sync issues?

Same as other users, I had to remove the sync chain between two computers and my phone to stop the duplicate bookmarks madness.

1 Like

@Mattches I’m seeing this for the ,140 release notes, but can you confirm if this fixes the main problem or is there still something to fix?

0.68.140

  • Fixed duplicate records being synced causing throttling issues. (#6125)

@Mattches I’ve seen mentions of Sync in the .141/.142 patch notes, so it’s good to see it’s being worked on, but is it safe yet to try again? I don’t mind test software out, I’m on plenty of other beta releases of other things, but not if it’s still guaranteed to mess up. Just going back to a pre .138 state would be enough.

@Taomyn,
These fixes have addressed crashes in some cases. I can’t guarantee yours will be included. Note that these are not the last of the Sync updates to fix crashes and our devs are still hammering out an all encompassing solution.

2 Likes

@Mattches I have 0.68.142 and experienced duplicate entries in my bookmarks. Also, when a duplicate was deleted, it reappeared.

So I used “Leave Sync Chain” on both computers. Now when I paste the passphrase on the second Mac, clicking on the button to continue does nothing.

I don’t see errors in the console or else.
What can I do?

@Sinklar,
We’re still resolving the duplicate bookmark entries issue – many users have encountered it and our devs are working hard to get it resolved.

You’re referring to the “confirm sync code” button? This happens every time? Also, you said “second” mac so I assume this means the other device you’re trying to link to the chain is also a mac?

1 Like

I understand.

Yes, I was talking about the “confirm sync code” button, and 2 Macs.

This morning I’ve been able to sync my 2 computers again. This time, this button to confirm the passphrase worked, and the spinner appeared. Then it took a really long time to complete but now my computers are in sync again.

1 Like

@Mattches so I decided to gave Sync a go again with v0.69.132 and I set up my main machine after exporting my bookmarks for backup. Then on my Android phone I cleared all its bookmarks and connected it to the sync chain. 12hrs later nothing - no new bookmarks on my phone, though nothing has disappeared on the main PC thankfully.

This morning on a work laptop running Windows, I added it to the sync chain, again I backed up its bookmarks before removing them. 2hrs later still nothing.

Is there any logging or something where I can look to see what the blazes is going on? Do I need to to switch something on to get console messages perhaps? For me Sync was actually working well until 0.68.138 but now it’s just simply 100% broken.

1 Like

Update: I was able to force a sync of bookmarks between my two PCs by deleting them all on the main machine, then re-importing them. Still waiting for them to appear on my Android phone though.

I really hope there’s a “Sync now” button with some kind of feedback in the roadmap for Sync.

1 Like

New issue now: the favicon of visited bookmarks keeps being reset. I few hours ago I could see over 10 on my bookmarks with their favicon, now they are all blank again.