Sync not working: "Brave was unable to access your system's secure storage..."

Description of the issue:

After the latest update (1.51.110) I started getting the “Brave was unable to access your system’s secure storage…” error. Everything was working fine before the update, I haven’t changed my password or anything in my configuration.

I’m running on Kubuntu 22.10.

I went through the troubleshooting guide at The “Brave Safe Storage” entry was not there, neither in the Login keyring nor in the list of keyrings. However, the FAQ article does not say which option to select after hitting +. I get 6 options: “Secure Shell key”, “GPG key”, “Password keyring”, “Password”, “Private key” and “Import from file…”. I tried creating a Password and it asks me for the password itself, and I also tried a Password keyring with the name “Brave Safe Storage” and using my login password as the password, but it’s not working.

Any ideas?


OK, so since I am running KDE it seems that I need to use the kdewallet app instead of “Passwords and Keys” (which is Gnome). I found the “Brave Safe Storage” password inside the “Brave Keys (1)/Passwords” folder in kdewallet. I copied it over to the “Passwords and Keys” wallet manager in the Login keychain. I then restarted Brave, but I’m still getting the same error.


Same problem with UbuntuStudio 22.04 (that is based on KUbuntu). And on top of that I do have to log-in to all sites (including 2FA) whenever I start Brave new.

Same here on desktop and laptop running openSUSE Tumbleweed with KDE. I can find nothing wrong with the KDE wallet. Everything was fine before the last updates.


@mcamou I’m guessing you’re looking at info such as you can see at BRAVE Sync - ERROR SECURE STORAGE - SYNC DISABLED - #6 by Mattches but saying not clear because you have all the key choices. If that’s the case, I can make assumptions but not 100% sure. I’ll just tag @Mattches here so he can try to follow up with you.,

1 Like

I just did a snapper rollback on the laptop to a few days ago and the problem persists. Is it possible that the problem is in the sync server and not on the local PCs.

I was just thinking a bit more about this. I updated the laptop this morning and it broke. I updated the desktop last night and I don’t remember it being broken until this morning. If I recall correctly, it was working fine before I went to bed. That would mean nothing changed on this end.

I was able to do a snapper roll back on the laptop, but I cannot try that on this desktop as I do not have BTRFS on it.

1 Like

Saoiray, I tried deleting the sync data from the thread from @Mattches. Since it is broken on both devices, I have no way to access the sync code to get it back.

I guess I will just lose all my sync data and have to start from scratch.

Same issue here with brave-browser-1.51.110-1.x86_64.rpm on openSUSE Tumbleweed. Reverting back to brave-browser-1.50.125-1.x86_64.rpm makes sync work again. Sync also works with the current beta and nightly builds, brave-browser-beta-1.52.86-1.x86_64.rpm and brave-browser-nightly-1.53.18-1.x86_64.rpm.

I also have an arm64 openSUSE Tumbleweed VM, and with brave-browser-1.51.110-1.aarch64.rpm sync works.

WORKS brave-browser-1.50.125-1.x86_64.rpm
FAILS brave-browser-1.51.110-1.x86_64.rpm
WORKS brave-browser-1.51.110-1.aarch64.rpm
WORKS brave-browser-beta-1.52.86-1.x86_64.rpm
WORKS brave-browser-nightly-1.53.18-1.x86_64.rpm

I could switch to the beta, but since both of my devices are broken, I have no way to get the sync chain.

Not sure yet, how to downgrade to 1.50.125-1

I need to dig that up.

@WilsonPhillips you mentioned you’re also on openSUSE Tumbleweed, so assuming the Brave repo is configured in YaST, you can downgrade using:

sudo zypper install --oldpackage brave-browser-1.50.125-1.x86_64

Alternatively grab the RPM package from and install using rpm:

sudo rpm -Uhv --oldpackage brave-browser-1.50.125-1.x86_64.rpm
1 Like

That worked, but it asks for the sync code and since both devices are broken, I have no way to access the sync code.

On the laptop, I think I will just wait it out and when it get fixed on the next update, I can grab the sync code from it. Hopefully.

I do appreciate the help though. :smile:

This is not good. We have solution when the storage is locked - then basically it is required just to unlock it.
But for the case when “Brave Safe Storage” was removed - we have not solution.

“Brave Safe Storage” contains the passphrase which is used to encrypt Brave Sync Seed, browser passwords and security cookies. This means that without “Brave Safe Storage” it is impossible to decrypt those mentioned entities.

I’ll try to reproduce it right now. I hope, the issue will show itself.

1 Like

Please see my reply here. NOTICE: Unexplained Data Loss Issue

If you need more, please ask. I will do what I can, but I am no expert.


To get previous release 1.50.125 working again on Kubuntu:

remove current release: sudo aptitude remove brave-browser

install previous release: sudo aptitude install brave-browser=1.50.125

apt and apt-get can similarly be used

To get the previous release working:

remove current release: sudo aptitude remove brave-browser

install previous release: sudo aptitude install brave-browser=1.50.125

apt and apt-get work similarly

I also have the issue. Removing the Brave Safe Storage key temporarily solves it, but it always breaks upon each restart of brave. It somehow wants to use a different key each time.

I have the same bug. I am using Fedora Linux with KDE Plasma, and I have Brave installed using Flatpak. I noticed that when updating to the latest version (1.51.110) I get this error in Brave Sync.

I went to: and checked the Why am I seeing the “Brave was unable to access your system’s secure storage…” error message? section.

After checking the section for Linux, I opened and checked the corresponding “Passwords and Keys” application in Plasma. When I run KWalletManager, the wallet is already open. And there is a section already created called “Brave Keys”. Within this a section called “Brave Safe Storage”, with a password already set.

On another computer on which I had not updated, I did not had this bug. After updating Brave and restarting the computer, I get the same bug on my other computer.

1 Like

Daniel, you can restore Brave to a previous version, but the keys will still be broken. You will need to input the Sync Code to get it working again. For you, that may or may not be possible. Hopefully, you have that Sync Code pasted into a text file somewhere.

I don’t know how long before this will get resolved.